HPE EVA Storage

how to connect multiple AD542C without HSV controller

Occasional Contributor

how to connect multiple AD542C without HSV controller

Greetings to all members of the group.
I ask for help from an expert to see if I can finally solve my difficulties. I explain the situation.
I have a workstation (HP Z420) with its corresponding HBA (LSI7404XP-LC). The board connects to two AD542C disk enclosures (14 x HD 500Gb FC) that are connected in series, so that the FC cable enters the upper connector of module A (M5413) of enclosure 1, and the lower connector of That M5413 comes out another cable that connects to cabinet 2. The disks have been assigned in windows not with letters but with "drive paths", such as: Cabin xx Disk YY,   with XX = 01, 02 and YY = 01, 02, ..., 14.
With this structure, the 28 discs are perfectly accessible and reading and writing on them is done without difficulty.

My idea was that instead of this structure, computer and each cabinet, they would be connected to a FC switch, but no matter how hard I tried, modifying the type of switch port I cannot communicate, it is impossible to access any disk.

I have tested with the following models:
Silkworm 24002800200E all of them type Fabric and 352 FC this a loop switch.

This is my question:
How should I configure the ports for any of these switches to act as a hub?
Don't these switch models allow such a configuration?

Thank you very much for the help.

Honored Contributor

Re: how to connect multiple AD542C without HSV controller


try this:

Set the Switch Ports as Loop ports

And the Default Zone to "all access"

  1. defzone --allaccess

  2. cfgsave


I'm not an HPE employee, so I can be wrong.
Occasional Contributor

Re: how to connect multiple AD542C without HSV controller

Thank you for your response Mr. Cali:

The defzone command with the allaccess addition is not in the Silkworm 2800, its operating system is 2.6.0h.
I have tried to see if any of the similar ones like Zonecreate worked but not.
I suppose there must be some hardware incompatibility because when connecting the FC from the AD542C to the 2800, the indicator led does not take on any color, neither amber nor green.
In a few days I will receive an old HUB 1036 from Compaq and we will see if the connection is possible with it.
In any case, thank you very much for the guidance.

Acclaimed Contributor

Re: how to connect multiple AD542C without HSV controller

I remember you told in the other thread (why opening multiple threads for a single problem?) you have the complete EVA.

WHat model is it?

Does it include switches for connecting the disk chassis to the controllers?

Consider to use them!

Hope this helps!

There are only 10 types of people in the world -
those who understand binary, and those who don't.

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Contributor

Re: how to connect multiple AD542C without HSV controller

Hello. Thanks for the reply.

I have from the old EVA system the 352FC Switch and the  Storage works 4/16 a Brocade 200E

Using the 352FC it perfectly detects the disk array and HBA of my HP Z420, and indicates that both ports are synchronized, but the Z420 cannot see the disks. I have made a lot of tests without results, accessing the port management console, the one with the HBA connected cannot see its WWn.
I've also tried using the Storage Server 4/16 SAN Switch (Brocade 200E) following the directions Cali gave me, but without success.
It is difficult for me to understand the reason that a direct connection (point to point) works but not when the Switch is there, I have been reading and reading about it for weeks but without luck.

Will follow.

Thanks again.

Occasional Contributor

Solved: how to connect multiple AD542C without HSV controller

Amazing, I found, by chance, the solution.

Connecting with Fiber (LC) and its corresponding transducer (Finisar) the Brocade 240E with the AD542C did not work in any way, but doing it with copper cable (SFP)... yes.

I have tried several of the ports of the Brocade and the same thing happens, so there is no question of the fiber cable problem.

Strange situation since the communication between the workstation and the disk cabinet made with LC fiber cable does not have any problem.

I will look for the explanation.

Thanks to all for the help.