HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Firmware baseline not updating all components

 
Kerry Quillen
Regular Advisor

Firmware baseline not updating all components

I have created and uploaded a custom SPP (using the 2019.03 SPP) for my Gen10 DL and BL managed servers in Oneview (v4.20.02).  This of course generates "profile is inconsistent" alerts.  After I execute "update from template" the DL servers will return an alert stating "One or more firmware components are inconsistent with the specified firmware baseline".  Turns out that all firmware components were upgraded except the Smart Array P408i-a SR Gen10 Embedded RAID controller.  If I mount the same ISO with ILO virtual media and boot from it, it upgrades all firmware including the array controller.  As a test, I uploaded the the full 2019.03 SPP and applied that via the Oneview profile with the same result - RAID controller does not upgrade.  Tried reapplying the profile a second time but still no luck.  I can't find anything within Oneview to indicate why that one component gets skipped.    I do firmware only updates in my profiles. These are all VM host servers.

3 REPLIES 3
MV3
HPE Pro

Re: Firmware baseline not updating all components

HI kerry,

Good Day!

Can you please try Power cycle the server and wait for the POST to complete, and reapply the server profile to update the firmware again and check.

Cheers,

 

Accept or Kudo
Kerry Quillen
Regular Advisor

Re: Firmware baseline not updating all components

I tried that.  Didn't work.  I created and uploaded a new custom SPP based on the latest 2019.09 SPP.  Applied that to a test server via the template/profile and it worked.   I'll roll that out during our next firmware update cycle which will be 6-9 months.

Kerry Quillen
Regular Advisor

Re: Firmware baseline not updating all components

I went ahead and created and tested a new template on 2 servers with the 2019.09 spp and it did the same thing.  I thn tested a 3rd by mounting the spp iso through virtual media and it worked.  I did however notice that instead of making one pass through it made 2.  The 2nd time around I saw this.  I can't find cp039732.zip in the spp so have no idea what it is but assume is the array controller firmware

spp.jpg