IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

deployment of portal server module on IMC fails

Eduardo_1
Member

deployment of portal server module on IMC fails

I have an IMC scenario where he IMC is installed in one server and the SQL in other server. I have already the installation working fine with a lot of modules already installed and deployd.

I tried to deploy a portal server module and the deployed stopped in the middle asking to see a error log.

Below you can see the last part of this error log where the error messages start

 

2011-01-04 00:22:34 [INFO ] [Thread-44] [com.h3c.imc.deploy.dma.wizard.a::run(409)] All works were done for component: iMC-UAM-PP

2011-01-04 00:34:00 [ERROR] [Database Checking Thread] [com.h3c.imc.deploy.dma.cX::z(876)] Access database error

java.sql.SQLException: Cannot open database "reportplat_db" requested by the login. The login failed.

                at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:368)

                at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2820)

                at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2258)

                at net.sourceforge.jtds.jdbc.TdsCore.login(TdsCore.java:603)

                at net.sourceforge.jtds.jdbc.ConnectionJDBC2.<init>(ConnectionJDBC2.java:357)

                at net.sourceforge.jtds.jdbc.ConnectionJDBC3.<init>(ConnectionJDBC3.java:50)

                at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:184)

                at java.sql.DriverManager.getConnection(DriverManager.java:582)

                at java.sql.DriverManager.getConnection(DriverManager.java:154)

                at com.h3c.imc.deploy.dma.cX.z(EnvPanel.java:843)

                at com.h3c.imc.deploy.dma.cX.a(EnvPanel.java:105)

                at com.h3c.imc.deploy.dma.w.run(EnvPanel.java:755)

2011-01-04 00:36:44 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.dma.s::c(726)] Component deploy state changed

 

My questions are:

 

Has anyone faced something like this?

 

Even if you have not seen this, can you give some clue to try solving the problem?

 

Thank you

 

Bye

Edu

1 REPLY
Eduardo_1
Member

Re: deployment of portal server module on IMC fails

A friend of mine was able to solve the problem.

 

What happened was that the IMC was installed in a Windows 2008 server. For some odd behavior in Windows 2008 even when you are logged in with an administrator account you do not have privileges as an administrator in the application "Intelligent Deployment Monitor Agent" and so any task you try to do usually does not work. For instance you can not deploy any module, you can not make a backup and so on. My friend discovered that when he tried to remove the module and then it received a message telling that he had not administrator privileges to do it.

The solution was to close the Intelligent Deploymet Monitor Agent application and start it again doing a right click and using the option "run as administrator", once this was done we were apple to deploy the portal module withou any problem.

What is strange is why the message about not having administrator privilege only appears when trying to remove the module and not when trying to deploy the module.

Anyway I believe it is a good idea every time doing operation with this Intelligent Deployment Monitor Agent to make sure you started it using the run as administrator option.