Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

SD2 firmware update question

 

SD2 firmware update question

Just received a critical alert about upgrading our SD2's to 2.53.0 firmware. We are currently at 2.51.102, so it looks like I can do this without bringing the servers down. I downloaded the zip file, expanded it, and transferred the bundle file to the /tmp directory on one of the SD2's in binary format. Went into the OA Firmware Update function and keyed in a URL of 'ftp://username:password@ipaddress/tmp/hpsd2-2.53.0-fw.bundle', but it comes back with "Firmware Update Cancelled: File Read error . . .may be bad URL". Not a lot to go on here. I used the OA CLI to ping the same ipaddress, and that works. So the server is reachable from the OA.

Any ideas?

Thanks,

Randy

3 REPLIES 3
Matti_Kurkela
Honored Contributor

Re: SD2 firmware update question

Check the log messages produced by the FTP server: maybe it has rejected the FTP login, and the rejection reason may be visible in the error message.

 

Can the username you used log in to the SD2 with FTP from some other system? Can the firmware bundle be downloaded after a successful FTP login? Maybe there is a permission problem.

MK

Re: SD2 firmware update question

Thanks for the response.

 

I checked my syslog on the ftp server, and there were no error messages.

 

I also tried the exact same url from a web browser on my workstation. I was able to download the bundle file to my workstation, so permissions is not an issue.

 

Perhaps this OA function is not really ready to use.

 

REK

Highlighted

Re: SD2 firmware update question

Turns out permissions must have been the issue. I changed the userid to root for the FTP, and it all worked. The process must do more than open the file for read.