LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast routing between twoe VLANS

 
Highlighted
Visitor

Multicast routing between twoe VLANS

Hello, All!

Collegues i am realy confused about distributing multicast traffic between twoe VLANS.

Config below. I need to recieve multicast in vlan 850 and route it to VLAN 8. I can use only topology like this, with twoe VLANS. I found info about PIM and trying to do same, but no result.

I am using HPE 5406 zl. 

Thanks in advice!

 ; J9850A Configuration Editor; Created on release #KB.15.15.0008
; Ver #05:18.7f.ff.3f.ef:4d
hostname "HP-5406Rzl2"
module A type j9637a
ip route 10.100.98.140 255.255.255.252 vlan 850
ip routing
ip multicast-routing
interface A1
name "IPTV_Provider"
exit
interface A2
name "Dell_Server"
exit
interface A3
name "VOIP_SW"
exit
interface A4
name "DVR"
exit
interface A7
name "Mikrotik_int4"
exit
snmp-server community "public" unrestricted
oobm
ip address dhcp-bootp
exit
router rip
redistribute connected
enable
exit
router pim
enable
bsr-candidate
bsr-candidate source-ip-vlan 850
rp-address 10.100.98.142 224.0.0.0 240.0.0.0
rp-candidate
rp-candidate source-ip-vlan 850
rp-candidate group-prefix 224.0.0.0 240.0.0.0
rp-candidate group-prefix 239.255.200.0 255.255.255.0
rp-candidate hold-time 150
exit
vlan 1
name "DEFAULT_VLAN"
no untagged A1-A5,A7-A12
untagged A6,A13-A24
ip address dhcp-bootp
exit
vlan 5
name "UPR"
tagged A14,A16,A19-A20,A22
ip address 192.168.55.1 255.255.255.0
exit
vlan 8
name "IPTV"
untagged A1-A2
tagged A14,A16,A19-A20,A22-A24
ip address 10.0.10.5 255.255.254.0
ip igmp
ip pim-sparse
ip-addr any
exit
forbid A13,A15,A17-A18,A21
exit
vlan 9
name "VLAN9"
no ip address
exit
vlan 115
name "IPPhone"
untagged A3
tagged A13-A24
no ip address
forbid A1-A2,A4
exit
vlan 116
name "Guest Network"
untagged A5
tagged A13-A24
no ip address
forbid A1-A2
exit
vlan 117
name "WiFi"
tagged A6,A13-A24
no ip address
forbid A1-A2
exit
vlan 120
name "WiFi Manage"
tagged A6,A13-A24
no ip address
forbid A1-A2
exit
vlan 121
name "WiFi Manage 2"
tagged A6,A13-A24
no ip address
forbid A1-A2
exit
vlan 122
name "WiFi Manage 3"
tagged A6,A13-A24
no ip address
forbid A1-A2
exit
vlan 125
name "CCTV"
untagged A4,A8-A12
tagged A13-A24
no ip address
forbid A1-A2
exit
vlan 850
name "IPTV_Provider"
untagged A7
ip address 10.100.98.142 255.255.255.252
ip igmp
ip pim-sparse
ip-addr any
exit
exit
vlan 900
name "Digital Signage"
tagged A13-A24
no ip address
forbid A1-A2
exit
spanning-tree

3 REPLIES 3
Highlighted
Occasional Collector

Re: Multicast routing between twoe VLANS

Hi,

I've got a simular problem. Looking at your config don't you need to enable RIP on the VLANs too. This is my config for one VLAN for example. Hope it helps.

vlan 10

   name "AIRTAME"

   untagged A22,C23

   ip address 192.168.3.10 255.255.255.0

   ip igmp

   ip rip 192.168.3.10

   ip pim-dense

      ip-addr any

      exit

Highlighted
Occasional Advisor

Re: Multicast routing between twoe VLANS

Hello,

Good day!

Wanted to know is there any specific reason you have configured BSR and RP on the same device?

Ideally, you should configure router-id as RP address.

Link connected to source and receiver should be configured with PIM.

Link connected to the receiver should be configured with IGMP.

 

Please find below link for more details.

 

https://community.hpe.com/t5/LAN-Routing/Multicast-routing-between-twoe-VLANS/m-p/7037119

 

Thanks!

I am an HPE employee.

 


I am a HPE Employee
Highlighted
Visitor

Re: Multicast routing between twoe VLANS

Thanks all for your replies.

10.100.98.142 - address of my switch

10.100.98.141 - PIM router by ISP.

I update config like below:

 

Running configuration:

; J9850A Configuration Editor; Created on release #KB.16.05.0012
; Ver #14:01.10.08.1d.fb.7f.bf.bb.ff.7c.59.fc.7b.ff.ff.fc.ff.ff.3f.ef:e1
hostname "HP-5406Rzl2"
module A type j9637a
ip routing
ip multicast-routing
interface A1
name "IPTV_Provider"
exit
interface A2
name "Dell_Server"
exit
interface A3
name "VOIP_SW"
exit
interface A4
name "DVR"
exit
interface A7
name "Mikrotik_int4"
exit
snmp-server community "public" unrestricted
oobm
ip address dhcp-bootp
exit
router rip
redistribute connected
exit
router pim
enable
rp-candidate
rp-candidate source-ip-vlan 850
rp-candidate group-prefix 224.0.0.0 240.0.0.0
rp-candidate hold-time 150
exit
vlan 1
name "DEFAULT_VLAN"
no untagged A1-A5,A7-A12
untagged A6,A13-A24
ip address dhcp-bootp
exit
vlan 5
name "UPR"
tagged A14,A16,A19-A20,A22
ip address 192.168.55.1 255.255.255.0
exit
vlan 8
name "IPTV"
untagged A1-A2
tagged A14,A16,A19-A20,A22-A24
ip address 10.0.10.5 255.255.254.0
ip igmp
ip rip 10.0.10.5
ip pim-sparse
ip-addr any
exit
forbid A13,A15,A17-A18,A21
exit
vlan 9
name "VLAN9"
no ip address
exit
vlan 115
name "IPPhone"
untagged A3
tagged A13-A24
no ip address
forbid A1-A2,A4
exit
vlan 116
name "Guest Network"
untagged A5
tagged A13-A24
no ip address
forbid A1-A2
exit
vlan 117
name "WiFi"
tagged A6,A13-A24
no ip address
forbid A1-A2
exit
vlan 120
name "WiFi Manage"
tagged A6,A13-A24
no ip address
forbid A1-A2
exit
vlan 121
name "WiFi Manage 2"
tagged A6,A13-A24
no ip address
forbid A1-A2
exit
vlan 122
name "WiFi Manage 3"
tagged A6,A13-A24
no ip address
forbid A1-A2
exit
vlan 125
name "CCTV"
untagged A4,A8-A12
tagged A13-A24
no ip address
forbid A1-A2
exit
vlan 850
name "IPTV_Provider"
untagged A7
ip address 10.100.98.142 255.255.255.252
ip rip 10.100.98.142
ip pim-sparse
ip-addr any
exit
exit
vlan 900
name "Digital Signage"
tagged A13-A24
no ip address
forbid A1-A2
exit
spanning-tree
device-profile name "default-ap-profile"
cos 0
exit
activate software-update disable
activate provision disable

 

But it is still dont works. I tryed to add rip config, but in network we doesn't rip, so no sense to config it only on one switch.

I use 10.100.98.142 as RP address, am i right? Or i shuld use remote address of ISP equipment?

I guess i dont need add static routes or any dynamic routing, i have direct connected IPTV source with address 10.100.98.141. Do i need RIP or OSPF? I already have route to 10.100.98.142.

Please any ideas?) I finish almost all docs about configuration PIM and still have no idea why it doesn't work. 

HELP NEEDED!!!