LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

inter-Vlan routing msr1003-8

 
SOLVED
Go to solution
Highlighted
Occasional Advisor

inter-Vlan routing msr1003-8

Hello everybody,

I first work with msr1003.

I have problem with inter-Vlan routing.

my test network:
laptop1 192.168.0.2/24 DG192.168.0.1/24
laptop2 192.168.1.2/24 DG192.168.1.1/24
3 com 2920 port1 vlan11 access/ port2 vlan22 access/ port10 vlan 11 22 trunk
msr1003:
port0/3 link-mode route
port0/3.11 vlan-type dot1q vid 11 ip192.168.0.1/24
port0/3.22 vlan-type dot1q vid 22 ip192.168.1.1/24

msr1003 ping all
laptops ping all
laptops not ping each othe

Why?
Where do I need to look?
In the documentation I can not find the necessary section

11 REPLIES 11
Highlighted
Occasional Advisor

Re: inter-Vlan routing msr1003-8

People,

Completed the settings for the documentation  Configuring VLAN termination (https://support.hpe.com/hpsc/doc/public/display?sp4ts.oid=4178998&docLocale=en_US&docId=emr_na-c05327929)
Does not work.

What else should I read?

Highlighted
Occasional Advisor

Re: inter-Vlan routing msr1003-8

There are specialists of the company HP?
Why I buy an expensive device I can not get normal technical support?

For inter-Vlan need conf ACL, PBR?

Highlighted
HPE Pro

Re: inter-Vlan routing msr1003-8

Hi,
 

Kindly look into the attached diagram and it seems to be similar like your network. Kindly Confirm.

Can you  share the current configuration of both of the devices (Router & Switch).

 

Thank You!

I am an HPE Employee

I am an HPE Employee

Accept or Kudo

Highlighted
Occasional Advisor

Re: inter-Vlan routing msr1003-8

Hi,

I'm very glad that someone answered.
The diagram is correct.

conf msr1003:
#Jan  1 01:09:20:314 2013 HPE SHELL/4/LOGIN:
 Trap 1.3.6.1.4.1.25506.2.2.1.1.3.0.1: login from Console
%Jan  1 01:09:20:314 2013 HPE SHELL/5/SHELL_LOGIN: Console logged in from aux0.
<HPE>sys
System View: return to User View with Ctrl+Z.
[HPE]dis current-configuration
#
 version 5.20.106, Release 2516P13
#
 sysname HPE
#
 firewall enable
#
 domain default enable system
#
 ip ttl-expires enable
 ip unreachables enable
 ip icmp-extensions compliant
#
 dar p2p signature-file flash:/p2p_default.mtd
#
 port-security enable
#
 password-recovery enable
#
acl number 2000
 rule 1 permit source 192.168.0.0 0.0.0.255
acl number 2001
 rule 1 permit source 192.168.1.0 0.0.0.255
#
vlan 1
#
domain system
 access-limit disable
 state active
 idle-cut disable
 self-service-url disable
#
user-group system
 group-attribute allow-guest
#
local-user admin
 password cipher $c$3$KORVvCVvx1zipr13BVmoYnokDZFAwXby
 authorization-attribute level 3
 service-type telnet
 service-type web
#
cwmp
 undo cwmp enable
#
interface Aux0
 async mode flow
 link-protocol ppp
#
interface Cellular0/0
 async mode protocol
 link-protocol ppp
#
interface NULL0
#
interface Vlan-interface1
#
interface GigabitEthernet0/0
 port link-mode route
 ip address 192.168.10.1 255.255.255.0
#
interface GigabitEthernet0/1
 port link-mode route
#
interface GigabitEthernet0/3
 port link-mode route
#
interface GigabitEthernet0/3.11
 vlan-type dot1q vid 11
 firewall packet-filter 2001 outbound
 ip address 192.168.0.1 255.255.255.0
#
interface GigabitEthernet0/3.22
 vlan-type dot1q vid 22
 firewall packet-filter 2000 outbound
 ip address 192.168.1.1 255.255.255.0
#
interface GigabitEthernet0/2
 port link-mode bridge
#
interface GigabitEthernet0/4
 port link-mode bridge
#
interface GigabitEthernet0/5
 port link-mode bridge
#
interface GigabitEthernet0/6
 port link-mode bridge
#
interface GigabitEthernet0/7
 port link-mode bridge
#
interface GigabitEthernet0/8
 port link-mode bridge
#
interface GigabitEthernet0/9
 port link-mode bridge
#
 load xml-configuration
#
 load tr069-configuration
#
user-interface tty 12
user-interface aux 0
user-interface vty 0 4
 authentication-mode scheme
#
return

 

conf 3com 2920:
#
 version 5.20 Release 1519P03
#
 sysname 3Com Baseline Switch
#
 domain default enable system
#
 password-recovery enable
#
vlan 1
#
vlan 11
#
vlan 22
#
domain system
 access-limit disable
 state active
 idle-cut disable
 self-service-url disable
#
user-group system
#
local-user admin
 authorization-attribute level 3
 service-type ssh telnet terminal
 service-type web
#
 stp mode rstp
 stp enable
#
interface NULL0
#
interface Vlan-interface1
 ip address 192.168.10.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port access vlan 11
 stp edged-port enable
#
interface GigabitEthernet1/0/2
 stp edged-port enable
#
interface GigabitEthernet1/0/3
 port access vlan 11
 stp edged-port enable
#
interface GigabitEthernet1/0/4
 stp edged-port enable
#
interface GigabitEthernet1/0/5
 port access vlan 22
 stp edged-port enable
#
interface GigabitEthernet1/0/6
 stp edged-port enable
#
interface GigabitEthernet1/0/7
 port access vlan 22
 stp edged-port enable
#
interface GigabitEthernet1/0/8
 stp edged-port enable
#
interface GigabitEthernet1/0/9
 stp edged-port enable
#
interface GigabitEthernet1/0/10
 port link-type hybrid
 port hybrid vlan 11 22 tagged
 port hybrid vlan 1 untagged
 stp edged-port enable
#
interface GigabitEthernet1/0/11
 stp edged-port enable
#
interface GigabitEthernet1/0/12
 stp edged-port enable
#
interface GigabitEthernet1/0/13
 stp edged-port enable
#
interface GigabitEthernet1/0/14
 stp edged-port enable
#
interface GigabitEthernet1/0/15
 stp edged-port enable
#
interface GigabitEthernet1/0/16
 stp edged-port enable
#
interface GigabitEthernet1/0/17
 stp edged-port enable
#
interface GigabitEthernet1/0/18
 stp edged-port enable
#
interface GigabitEthernet1/0/19
 stp edged-port enable
#
interface GigabitEthernet1/0/20
 stp edged-port enable
#
 snmp-agent
 snmp-agent local-engineid 8000002B0320FDF16DEC14
 snmp-agent sys-info version v3
#
user-interface aux 0
 authentication-mode scheme
user-interface vty 0 15
 authentication-mode scheme
#
return

Thank you!

Highlighted
HPE Pro

Re: inter-Vlan routing msr1003-8

Hi,

Thank You for your reply!

Can you mention which port of 2920 is connecting to MSR 1003?

i believe MSR 1003 interface 0/3 is coneecting to 2920 switch? Kindly correct me if I am wrong.

 

Thank You!

I am an HPE Employee

I am an HPE Employee

Accept or Kudo

Highlighted
Occasional Advisor

Re: inter-Vlan routing msr1003-8

2920:
port1/0/10

msr1003:
port0/3

msr1003:
[HPE]dis ip routing-table
Routing Tables: Public
        Destinations : 6        Routes : 6
Destination/Mask    Proto  Pre  Cost         NextHop         Interface
127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0
127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0
192.168.0.0/24      Direct 0    0            192.168.0.1     GE0/3.11
192.168.0.1/32      Direct 0    0            127.0.0.1       InLoop0
192.168.1.0/24      Direct 0    0            192.168.1.1     GE0/3.22
192.168.1.1/32      Direct 0    0            127.0.0.1       InLoop0
[HPE]

Highlighted
HPE Pro

Re: inter-Vlan routing msr1003-8

Hi,

I have replicated the same into simulator and it is working fine for me.

PC1 on different VLAN is able to Ping PC2 on different VLAN and similarly for PC2 to PC1.

For testing purpose tried in both ways:

1. Similary like you configuration where MSR port is in route mode and 2920 port is trunk.

2. Create vlan interface 11 & 22 on MSR router and port connecting to switch make as trunk port and pass the vlan.

In my setup I have used one msr router, one comware switch and 2 PC's.

Can you try after removing firewall commands on both of the switches?

If still issue remains then kindly log a case with support.

 

Thank You!

I am an HPE Employee

I am an HPE Employee

Accept or Kudo

Highlighted
Occasional Advisor

Re: inter-Vlan routing msr1003-8

2. Create vlan interface 11 & 22 on MSR router...
I do not quite understand what it means.

interface Vlan-interface11
ip address 192.168.0.1 255.255.255.0
interface Vlan-interface22
ip address 192.168.1.1 255.255.255.0
interface GigabitEthernet0/3
port link-mode route

or

interface GigabitEthernet0/3
port link-mode route
interface GigabitEthernet0/3.11
vlan-type dot1q vid 11
ip address 192.168.0.1/24
interface GigabitEthernet0/3.22
vlan-type dot1q vid 22
ip address 192.168.1.1/24

I removed firewall, but no result.
Can I see your configuration msr?

Highlighted
HPE Pro
Solution

Re: inter-Vlan routing msr1003-8

Hi,

For me it worked from both type. Below is the configuration of both types:


1. MSR while using Router on Stick:

#
interface GigabitEthernet0/0
port link-mode route
combo enable copper
#
interface GigabitEthernet0/0.11
ip address 192.168.0.1 255.255.255.0
vlan-type dot1q vid 11
#
interface GigabitEthernet0/0.22
ip address 192.168.1.1 255.255.255.0
vlan-type dot1q vid 22
#

Ping Result:

<H3C>ping 192.168.0.1
Ping 192.168.0.1 (192.168.0.1): 56 data bytes, press CTRL_C to break
56 bytes from 192.168.0.1: icmp_seq=0 ttl=255 time=2.000 ms
56 bytes from 192.168.0.1: icmp_seq=1 ttl=255 time=1.000 ms
56 bytes from 192.168.0.1: icmp_seq=2 ttl=255 time=1.000 ms
56 bytes from 192.168.0.1: icmp_seq=3 ttl=255 time=2.000 ms
56 bytes from 192.168.0.1: icmp_seq=4 ttl=255 time=1.000 ms

--- Ping statistics for 192.168.0.1 ---
5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 1.000/1.400/2.000/0.490 ms
<H3C>%Sep 13 17:18:51:539 2018 H3C PING/6/PING_STATISTICS: Ping statistics for 192.168.0.1: 5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 1.000/1.400/2.000/0.490 ms.

<H3C>ping 192.168.1.1
Ping 192.168.1.1 (192.168.1.1): 56 data bytes, press CTRL_C to break
56 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=2.000 ms
56 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=1.000 ms
56 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=2.000 ms
56 bytes from 192.168.1.1: icmp_seq=3 ttl=255 time=1.000 ms

--- Ping statistics for 192.168.1.1 ---
4 packet(s) transmitted, 4 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 1.000/1.500/2.000/0.500 ms
<H3C>%Sep 13 17:18:58:540 2018 H3C PING/6/PING_STATISTICS: Ping statistics for 192.168.1.1: 4 packet(s) transmitted, 4 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 1.000/1.500/2.000/0.500 ms.
ping 192.168.1.2
Ping 192.168.1.2 (192.168.1.2): 56 data bytes, press CTRL_C to break
56 bytes from 192.168.1.2: icmp_seq=0 ttl=254 time=3.000 ms
56 bytes from 192.168.1.2: icmp_seq=1 ttl=254 time=3.000 ms
56 bytes from 192.168.1.2: icmp_seq=2 ttl=254 time=2.000 ms
56 bytes from 192.168.1.2: icmp_seq=3 ttl=254 time=3.000 ms

--- Ping statistics for 192.168.1.2 ---
4 packet(s) transmitted, 4 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 2.000/2.750/3.000/0.433 ms
<H3C>%Sep 13 17:19:01:983 2018 H3C PING/6/PING_STATISTICS: Ping statistics for 192.168.1.2: 4 packet(s) transmitted, 4 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 2.000/2.750/3.000/0.433 ms.


2. MSR while using bridge mode and passing vlan 11 & 22

interface Vlan-interface11
ip address 192.168.0.1 255.255.255.0
#
interface Vlan-interface22
ip address 192.168.1.1 255.255.255.0
#

#
interface GigabitEthernet0/0
port link-mode bridge
port link-type trunk
port trunk permit vlan all
combo enable copper
#

Ping Result:


<H3C>ping 192.168.1.1
Ping 192.168.1.1 (192.168.1.1): 56 data bytes, press CTRL_C to break
56 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=6.000 ms
56 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=2.000 ms
56 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=1.000 ms
56 bytes from 192.168.1.1: icmp_seq=3 ttl=255 time=1.000 ms

--- Ping statistics for 192.168.1.1 ---
4 packet(s) transmitted, 4 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 1.000/2.500/6.000/2.062 ms
<H3C>%Sep 13 17:26:26:937 2018 H3C PING/6/PING_STATISTICS: Ping statistics for 192.168.1.1: 4 packet(s) transmitted, 4 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 1.000/2.500/6.000/2.062 ms.
ping 192.168.1.2
Ping 192.168.1.2 (192.168.1.2): 56 data bytes, press CTRL_C to break
56 bytes from 192.168.1.2: icmp_seq=0 ttl=255 time=0.000 ms
56 bytes from 192.168.1.2: icmp_seq=1 ttl=255 time=0.000 ms
56 bytes from 192.168.1.2: icmp_seq=2 ttl=255 time=0.000 ms

--- Ping statistics for 192.168.1.2 ---
3 packet(s) transmitted, 3 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 0.000/0.000/0.000/0.000 ms
<H3C>%Sep 13 17:26:28:971 2018 H3C PING/6/PING_STATISTICS: Ping statistics for 192.168.1.2: 3 packet(s) transmitted, 3 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 0.000/0.000/0.000/0.000 ms.
ping 192.168.0.1
Ping 192.168.0.1 (192.168.0.1): 56 data bytes, press CTRL_C to break
56 bytes from 192.168.0.1: icmp_seq=0 ttl=255 time=2.000 ms
56 bytes from 192.168.0.1: icmp_seq=1 ttl=255 time=1.000 ms

--- Ping statistics for 192.168.0.1 ---
2 packet(s) transmitted, 2 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 1.000/1.500/2.000/0.500 ms
<H3C>%Sep 13 17:26:33:212 2018 H3C PING/6/PING_STATISTICS: Ping statistics for 192.168.0.1: 2 packet(s) transmitted, 2 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 1.000/1.500/2.000/0.500 ms.
ping 192.168.0.2
Ping 192.168.0.2 (192.168.0.2): 56 data bytes, press CTRL_C to break
56 bytes from 192.168.0.2: icmp_seq=0 ttl=254 time=6.000 ms
56 bytes from 192.168.0.2: icmp_seq=1 ttl=254 time=8.000 ms
56 bytes from 192.168.0.2: icmp_seq=2 ttl=254 time=3.000 ms

--- Ping statistics for 192.168.0.2 ---
3 packet(s) transmitted, 3 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 3.000/5.667/8.000/2.055 ms
<H3C>%Sep 13 17:26:35:358 2018 H3C PING/6/PING_STATISTICS: Ping statistics for 192.168.0.2: 3 packet(s) transmitted, 3 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 3.000/5.667/8.000/2.055 ms.


Have you removed firewall and acl from interfaces as well?
If the issue remains then kindly log a case with support.

Thank You!
I am an HPE Employee

 

I am an HPE Employee

Accept or Kudo