cancel
Showing results for 
Search instead for 
Did you mean: 

Re: vgcreate problem

 
SOLVED
Go to solution
Occasional Advisor

vgcreate problem

Hello HP-UX experts,

I have a problem with the creation of a volume group. I have the error

# vgcreate /dev/vglega /dev/dsk/c6t2d0

Warning: Max_PE_per_PV for the volume group (65535) too small for this PV
(369258).

Using only 65535 PEs from this physical volume.
Increased the number of physical extents per physical volume to 65535.
vgcreate: Volume group "/dev/vgeur" could not be created:
File too large


What's the problem?

Thanks.

Gian Luca
6 REPLIES 6
Honored Contributor
Solution

Re: vgcreate problem

The volume is too big for the defualt PE size of 4MB.

Try:

vgcreate -s 32 /dev/vglega /dev/dsk/c6t2d0

You may even want to use 64MB.

HTH.
Honored Contributor

Re: vgcreate problem

Try increasing the size of the physical extents

"vgcreate -s 32 /dev/vgeur"

The maximum number of PE is 65535 and the default size is 4MB so you ned to make them bigger
Never preceed any demonstration with anything more predictive than "watch this"
Honored Contributor

Re: vgcreate problem

A disk in a volume group can hold a maximum of 65535 PE , Physical extents of default size 4MB .

The default size of 4 MB per PE is too small for this disk that you are trying to create the VG on .

So increase the size of the PE in powers of 2 to fit the size of the physixal disk .

do man vgcreate for more options ( seee the -s and -e options )
Honored Contributor

Re: vgcreate problem

Hi Gianluca,

problem is about PE_SIZE, see doc KBRC00009036.
You should execute vgcreate with -s option, e.g.

# vgcreate -s 16 /dev7vglega /dev/dsk/c6t2d0

I hope this helps you.

Best regards,
Ettore
WISH? IMPROVEMENT!
Occasional Advisor

Re: vgcreate problem

Thanks a lot at all for quick replies!!!

# vgcreate -s 32 /dev/vglega /dev/dsk/c6t2d0

and vglega was created successfully.

Thanks again!

Gian Luca
Honored Contributor

Re: vgcreate problem

the problem here is that the vg extent info has to be able to fit in one PE. If the table exceeds the PE size (default 4MB) then it fails with "file too large". To work around this you have to either

-increase the PE size
-decrease the max number of PV (def 16)
-decrease the max number of LV (def 255)
-use combo of PV/LV/PE size


ex:/

vgcreate -s 8 -p 5 -l 20 /dev/vglega /dev/dsk/c6t2d0

where:
-s = pe size
-p = max# PV
-l = max# LV

For a large lun/disk usually a combo of reducing the max# of PV/LV and the PE size should do it.

Hope this helps,
-Denver