Languages and Scripting

problem in building binutils on hpux 11.31 ipf m/c

 
SOLVED
Go to solution
NagarajSG
Occasional Advisor

problem in building binutils on hpux 11.31 ipf m/c

Hello,
I am trying to build binutils on hpux11iv3 ipf m/c. I am getting the following erreors


"binemul.c", line 28: error #2029: expected an expression
if (bin_dummy_emulation.ar_usage)
^

"binemul.c", line 29: error #2029: expected an expression
bin_dummy_emulation.ar_usage (fp);
^

"binemul.c", line 43: error #2029: expected an expression
if (bin_dummy_emulation.ar_append)
^

"binemul.c", line 44: error #2029: expected an expression
return bin_dummy_emulation.ar_append (after_bfd, file_name, verbose);
^

"binemul.c", line 69: error #2029: expected an expression
if (bin_dummy_emulation.ar_replace)
^

"binemul.c", line 70: error #2029: expected an expression
return bin_dummy_emulation.ar_replace (after_bfd, file_name, verbose);
^

"binemul.c", line 95: error #2029: expected an expression
if (bin_dummy_emulation.ar_parse_arg)
^

"binemul.c", line 96: error #2029: expected an expression
return bin_dummy_emulation.ar_parse_arg (arg);
^

8 errors detected in the compilation of "binemul.c".
gmake[4]: *** [binemul.o] Error 2
gmake[4]: Leaving directory `/home/bbslave/ocek/modules/binutils/2.17/binutils-2.17/binutils'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/home/bbslave/ocek/modules/binutils/2.17/binutils-2.17/binutils'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/home/bbslave/ocek/modules/binutils/2.17/binutils-2.17/binutils'
gmake[1]: *** [all-binutils] Error 2
gmake[1]: Leaving directory `/home/bbslave/ocek/modules/binutils/2.17/binutils-2.17'
gmake: *** [all] Error 2


i am attaching the log with this

Regards
Nagaraj
10 REPLIES 10
Dennis Handly
Acclaimed Contributor

Re: problem in building binutils on hpux 11.31 ipf m/c

Your error message indicates that bin_dummy_emulation is bad. Your makefile output seems to have this: -Dbin_dummy_emulation
This sets bin_dummy_emulation to "1", not a valid name for an object that's a struct.
Michal Tuma
New Member

Re: problem in building binutils on hpux 11.31 ipf m/c

Hi,
what about installing depot of gcc, which contains binutils.

Try this one.
http://gatekeep.cs.utah.edu/hppd/hpux/Gnu/gcc-4.2.3/

Best regards,
Michal
NagarajSG
Occasional Advisor

Re: problem in building binutils on hpux 11.31 ipf m/c

but the same code is working fine with 11vi1 and 11v2i
Dennis Handly
Acclaimed Contributor

Re: problem in building binutils on hpux 11.31 ipf m/c

>but the same code is working fine with 11i v1 and 11i v2

There were massive changes in the system headers for 11.31 for UNIX 2003 branding and C99.

NagarajSG
Occasional Advisor

Re: problem in building binutils on hpux 11.31 ipf m/c


so tell me what are the changes i need to do to work this code currectly
Dennis Handly
Acclaimed Contributor

Re: problem in building binutils on hpux 11.31 ipf m/c

>so tell me what are the changes I need to do to work this code correctly

You'll need to debug your config script to see why -Dbin_dummy_emulation= is being set.

>This sets bin_dummy_emulation to "1"

Oops, since there was a "=", it is replaced by an empty string.
Steve Ellcey
Valued Contributor

Re: problem in building binutils on hpux 11.31 ipf m/c

My configure and make seem to be going OK. After configure I looked at binutils/Makefile and it has

EMULATION_VECTOR = bin_vanilla_emulation

and later

-Dbin_dummy_emulation=$(EMULATION_VECTOR)

Are these lines in your Makefile? (Not the top level makefile but the one below it in the binutils directory.

Also, are you using the right make? I think you need to use gnu Make and not the standard HP make.
NagarajSG
Occasional Advisor

Re: problem in building binutils on hpux 11.31 ipf m/c

My configure and make seem to be going OK. After configure I looked at binutils/Makefile and it has

EMULATION_VECTOR =
is not set to bin_vanilla_emulation

and
-Dbin_dummy_emulation=$(EMULATION_VECTOR)

is setting properly
i am using gnu make 3.81 version.

Regards
Nagaraj
Steve Ellcey
Valued Contributor
Solution

Re: problem in building binutils on hpux 11.31 ipf m/c

What options, if any, are you passing to configure? Are you using --host, --target, or --build options on the configure call? Or perhaps the --enable-targets option? An illegal target name is the only way I can see that EMULATION_VECTOR would get set to nothing.