BladeSystem Forums have moved here
To make BladeSystem information easier to find, we have moved the BladeSystem forums here, to Servers and Operating Systems.
Languages and Scripting
Showing results for 
Search instead for 
Do you mean 

shared library core dump


shared library core dump

I created the executable following option


and created on HP 11.0 and using ANSI C++ B3910B A.03.25 compiler

while executing, core dump and following is the trace
#0 0x7a9c4ab8 in () from /usr/lib/Motif2.1/libXm.4
#1 0x7aaefe2c in _XmAddHashEntry () from /usr/lib/Motif2.1/libXm.4
#2 0x7aae8250 in XmeTraitSet () from /usr/lib/Motif2.1/libXm.4
#3 0x7aabb6e4 in ClassPartInitialize () from /usr/lib/Motif2.1/libXm.4
#4 0x7abdefe4 in CallClassPartInit () from /usr/lib/X11R6/libXt.3
#5 0x7abdf1ec in XtInitializeWidgetClass () from /usr/lib/X11R6/libXt.3
#6 0x7abdf1c8 in XtInitializeWidgetClass () from /usr/lib/X11R6/libXt.3
#7 0x7abdf1c8 in XtInitializeWidgetClass () from /usr/lib/X11R6/libXt.3
#8 0x7abdff88 in _XtCreateWidget () from /usr/lib/X11R6/libXt.3
#9 0x7ac163ec in _XtVaCreateWidget () from /usr/lib/X11R6/libXt.3
#10 0x7ac1668c in XtVaCreateManagedWidget () from /usr/lib/X11R6/libXt.3

please give me the solution. do we need any patch. I tried with static options. i could't succeded.

I will appreciate your help
Honored Contributor

Re: shared library core dump


Here is the list of patches you should have.

s700_800 11.00 HP aC++ (A.03.05) to fix numerous defects(PHSS_13391)
s700_800 11.00 Standard Component header file fixes(PHSS_13498)
s700_800 11.x HP aC++ runtime libraries (aCC A.03.13)(PHSS_16587)
s700_800 11.00 HP aC++ (A.03.15)(PHSS_20975)
s700_800 11.00 ANSI C compiler cumulative patch(PHSS_22272)
s700_800 11.X HP aC++ -AA header files (aCC A.03.30)(PHSS_22868)
s700_800 11.00 ld(1) and linker tools cumulative patch(PHSS_23440)
s700_800 11.X ANSI C compiler B.11.11.02 cumulative patch(PHSS_24830)
s700_800 11.X HP aC++ Compiler (aCC A.03.31)(PHSS_25170)

some of these may not be applicable to you. Some more may be required. Do a patch analysis and hopefullt you will be able to find if you need any patch.

Hope this helps.

Esteemed Contributor

Re: shared library core dump


I think this is because of pacthes are not loaded/not loaded in order. Please load all supeceded patches with pre requisite. I hope ur problem will get solved.

With rgds, Shahul
Honored Contributor

Re: shared library core dump

That stack trace looks reasonable up to the moment that it dumped core. The code would be manipulating malloc allocated hash table data structures. You could look at the program with wdb and the Tools->Memory Check feature to watch for corruption of malloc memory. You could use Purify if you have it licensed.

Re: shared library core dump

Updated listed paches, even it crashes once again at the same level

do we need PHSS_23823 patch?.


Re: shared library core dump

According to Mike, i debugged the problem. no memory leak or corrept before calling XtVaCreateManagedWidget motif function.

It crashes at this point and it gave above traced path.

Even If i use same functionality at the begining of the main application.
same core is happening.


Re: shared library core dump

any comments from you. waiting for your valuable suggestions
Honored Contributor

Re: shared library core dump


Seems like you can try patch PHSS_23823. It does says it solves some of the problems.

I'll say give it a try. Hope it helps.

Honored Contributor

Re: shared library core dump

Can you create and post a small example that demonstrates the crash?

Re: shared library core dump

Regarding to Mike,

for small exmple, it is working. This example does not use xaw library and Xmu library.

My application is using tree widgets and it uses library Xaw and Xmu.

this applcation tested in motif 1.1 version.

Also tested on 10.20. no changes from application point of view. only change in HP OS.

if i am creating the version with following option


it gives display can set error. this message already posted.

even this problem is happening to a small program..

Honored Contributor

Re: shared library core dump

You could either add to your example until it fails or simplify your application build until it works. The unspecified "tree widget" seems suspicious. Any widget that subclasses from Motif widgets should be examined in the context of the "Motif Widget Writer's Guide"-
ext of the

The "-a,archive" problem is likely to be a link order problem. You did not actually specify your link line. The following link line works for a simple test program-
cc -o p p.c -Wl,-a,archive -L/usr/lib/X11R6 -lXm -lXp -lXt -lXext -lX11 -lm