MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA 2040 Firmware Update | Failed/Stuck?

 
AR7
Occasional Visitor

MSA 2040 Firmware Update | Failed/Stuck?

Hi All,

We have a dual controller MSA 2040, which the other weekend I set off to update firmware from early release to current, I think GL105 to now GL220.

Anyway, started this on what I found was Controller B, via the web GUI. It all seemed to progress along well with items displaying onscreen until it said it would reboot or something. I let this happen and then after a while I could again reach the web GUI, which now looked different as it was the v3 version, BUT, could not log in as it had a warning to say it was still initialising.

Logged into controller A web GUI and it showed B as being offline.

So trying to resolve this this week and found that I could still connect into B via SSH, but only do things within Management Controller (MC), sending any commands to the Storage Controller (SC) has it fail.
So, after reading some other things I thought to completely power cycle the unit, so today stopped all I/O and then set the command from Controller A to Shutdown SC on both A and B. Power cycled unit.. AND...

Now I can't reach the Web GUI/CLI on A. I can CLI into B with limited functions. Tried to connect via USB method but windows said it couldn't function with this USB item, using server 2012 driver on win 10 so maybe something a miss there, will connect to server to try.

Otherwise, everything is still working, but I have no visibility, and no firmware updated.

Any hints or thoughts on how to proceed to get back to a functioning controller?
From memory Controller A now has a solid amber light at back, and Controller B is flashing.

I've moved some items off the MSA now and could get the rest off this week if need be to nuke and start again but would rather not if I can.

Cheers

6 REPLIES 6
Cali
Honored Contributor

Re: MSA 2040 Firmware Update | Failed/Stuck?

Hello,

for the USB/Serial Connection you need this Driver:

HP MSA 1040/2040 and P2000 G3 USB Driver for Windows Server x64

http://h20565.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=1008632546&swItemId=MTX_ae894f585aee4217829954b940&swEnvOid=4064

Than check the State with:

show system

show controller

show version

Do not use the Web Console for Updates, use the Windows Tool:

Online ROM Flash Component for Windows - HPE MSA 1040/2040 Storage Arrays

From GL105 to GL220 insert Step GL200P002.


======================
That was not planned in this way.
iamjawad
Advisor

Re: MSA 2040 Firmware Update | Failed/Stuck?

Hi,

 

First, make sure both the controllers are on the same firmware. #show controllers.

As you have access to controller B CLI issue command # restart mc a.

post the o/p of #show controllers. & # show versions 

 

 

AR7
Occasional Visitor

Re: MSA 2040 Firmware Update | Failed/Stuck?

Hi Cali,

That is the USB driver I had tried, but seems like it worked this time after I had rebooted my laptop. Either way, it didn't give me any more functions than I had via TCP SSH session which still worked.

In the end, I found that if I removed controller A, controller B would function 95%, so web interface would load and I could login, but then it would loop to logging in again.

I tried moving controllers around, and running individually and A was just unresponsive no matter what. So, that got replaced by HPE now. B is sort of working, but not 100% so that too is getting replaced.

It's been fun..

AR7
Occasional Visitor

Re: MSA 2040 Firmware Update | Failed/Stuck?

Hi iamjawad,

Yeah, couldn't do much to pull controller A details, as if both were plugged in, both would have limited functionality. Thanks for the tips, will use them next time around, but for now, we're getting some assistance from HPE to resolve this.

Mazzucconi
Occasional Visitor

Re: MSA 2040 Firmware Update | Failed/Stuck?

Hello,

where we can find the upgrade path? You said "From GL105 to GL220 insert Step GL200P002" and it's a good advise but is there a document to check prior to start a MSA firmware upgrade? In my case I would like to upgrade from GL105 to GL225R003. Thank you.

Kipp_Glover
Neighborhood Moderator

Re: MSA 2040 Firmware Update | Failed/Stuck?

Hi Mazzucconi!

There is no upgrade path needed for the "GL" line of controller firmware (MSA 2040/2042/1040).  The recommended best practice is to use the Linux or Windows Smart Component to upgrade the MSA Controller firmware.    Please reference www.hpe.com/storage/MSAFirmware for links to the smart components for the current MSA controller firmware.  

Cheers!
/Kipp

I am an HPE Employee

Accept or Kudo