Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

HPUX odd hostname+networking issue

SOLVED
Go to solution
Matthew Darcy_2
Frequent Advisor

HPUX odd hostname+networking issue

I've just done a clean HPUX 11.31 install on an RX2600 from DVD media.

The install went fine, big package set no problems.

the hostname of the machine is igniteux01 and is set in netconf, no issues.

[quote]
HOSTNAME=igniteux01
OPERATING_SYSTEM=HP-UX
LOOPBACK_ADDRESS=127.0.0.1
[/quote]

when the machine boots and I run "hostname" it returns "igniteux01"

however if I run "uname -n" it returns "igniteux" rather than "igniteux01"

I have no idea whats causing uname to drop the 01. This is pretty much the first boot after install so nothings been set.

I'm also having some odd networking issues with the machine.

To debug this I've set nsswitch.conf to resolve from files only.

[quote]
hosts: files
[/quote]

if I ping localhost I a 5 minute delay, then it starts responding

[quote]
# ping localhost
PING localhost: 64 byte packets
64 bytes from 127.0.0.1: icmp_seq=0. time=0. ms
[/quote]

but it really is approx 300 seconds before it starts to run, almost as if it's doing a lookup in the background and waiting for it to time out. if I ping 127.0.0.1 it responds straight away.

if I do an nslookup (remember it's working on files only) it responds straight away

# nslookup
Using /etc/hosts on: igniteux01

> localhost
Using /etc/hosts on: igniteux01

looking up FILES
Name: localhost
Address: 127.0.0.1
Aliases: loopback


I suspect this is all down to the igniteux01/igniteux naming issue, so I'd like to resolve/understand that and then move on.




3 REPLIES
Earl_Crowder
Trusted Contributor
Solution

Re: HPUX odd hostname+networking issue

hosts is no longer enough in nsswitch.conf, need ipnodes as well:

ipnodes: files
hosts: files

Also,
man nodehostnamesize

Setting nodenames larger than 8 bytes requires setting a configuration option.
Matthew Darcy_2
Frequent Advisor

Re: HPUX odd hostname+networking issue

the hostname issue I knew about, but thought was an old legacy issue that had been resolved, changing it to ignite01 was simpler than the additional configuration requried.

I have no idea why ipodes wasn't in nsswitch.conf, I didn't notice it missing either, I've just added it and the box has pretty much come to life.

thanks,

Bill Hassell
Honored Contributor

Re: HPUX odd hostname+networking issue

> I have no idea why ipodes wasn't in nsswitch.conf

nsswitch.conf is woefully lacking in documentation. The examples in /etc are not useful either. ipnodes is used for IPv6 compatibility and can be backported to 11.11 so all your systems have the same nsswitch.conf file. Here's a useful version with DNS as a fallback:

passwd: files
group: files
hosts: files [NOTFOUND=continue UNAVAIL=continue] dns
ipnodes: files
services: files
networks: files
protocols: files
rpc: files
publickey: files
netgroup: files
automount: files
aliases: files

I would not add dns to ipnodes unless you know that your DNS server understands IPv6 addresses (whether you use them or not). Otherwise, you may experience connection delays as the local resolver tries to identify an IP given a hostname. Use nsquery rather than nslookup for better information about hostname/IP lookups.


Bill Hassell, sysadmin