Showing results for 
Search instead for 
Do you mean 

NFS client fails to read DNFS disk

Honored Contributor [Founder]

NFS client fails to read DNFS disk

Hi All


Alpha VMS 7.3-2, Tcpip 5.4 Eco 7


I started NFS client, and want to "talk" to a Windows Server 2008 NFS Server (Microsoft NFS)


IRIS>tcpip mount dnfs1: /host=agbvsorawin/path="DIRUTL"/USER=DEFAULT/UID=-2/GID=-2
IRIS>dir DNFS1:[000000]
%DIRECT-E-OPENIN, error opening DNFS1:[000000]*.*;* as input
-RMS-E-DNF, directory not found
-SYSTEM-F-PROTOCOL, network protocol error
IRIS>sh dev dnfs1

Device                  Device           Error    Volume         Free  Trans Mnt
 Name                   Status           Count     Label        Blocks Count Cnt
DNFS1:          (IRIS)  Mounted              0  AGBVS$DIRUTL  79367224     1   1


IRIS>tcpip sh mount dnfs1/ful
%TCPIP$DNFSMOUNT-E-SHOWFAIL, error showing information for SYS$SYSROOT:[000000]DNFS1.;
-RMS-F-DEV, error in device name or inappropriate device type for operation


Wireshark says wet a

getattr error, header checksum error


Thanks for any hint

Honored Contributor [Founder]

Re: NFS client fails to read DNFS disk

By the way, while I know many logicals exist for debugging or modifying the behavior of Ftp/Lpd/Telnetsym...


I have been to find any logical for nfs client, to be more verbose, for example.


Did I miss something obvious ?

Honored Contributor [Founder]

Re: NFS client fails to read DNFS disk

It eventually works with /noadf


I am a bit disappointed, as I had planned to test with /adf=...


By the way, this is the first time I see a device in a MOUNTED state (not MOUNTED DISMOUNTED or MOUNTED UNAVAILABLE or...) that is in fact unavailable!



Occasional Visitor

Re: NFS client fails to read DNFS disk

Hi, had the same issue in the same basic environment* as you, and the /NOADF worked for me too.


However now any attempt at accessing or doing a directory (or doing a TCPIP>DISMOUNT) on my DNFS1 gives me an access violation, e.g.

%DIRECT-E-OPENIN, error opening DNFS1:[000000]*.*;* as input

-RMS-E-PRV, insufficient privilege or file protection violation


On the server's share side's properties I had selected "No Server Authentication", "Enable unmapped user access", and Allow anonymous access" (w/ UID=-2, GID=-2).  In Share Permissions, "ALL MACHINES" has Read-Write access (and I've tried both with and without "Root Access Allowed"


On the VMS/Client side, I've tried your exact format of mount, and a few variations.  I had originally set up TCPIP$NOBODY -2, -2 in the Proxy table (/HOST=*), but noticing the NFS connection was done with user DEFAULT, changed the Proxy entry to User DEFAULT (and removed the Disuser flag from DEFAULT in UAF>).


BTW we don't have any actual Unix Attributes (GID/UID etc.) set up in our Windows environment.


Any clues/examples re your setup would be appreciated.


* Client on HP TCP/IP Services for OpenVMS Industry Standard 64 Version V5.6, OpenVMS V8.3

   NFS Server setup on Windows Server 2008 R2 Enterprise SP1