Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Microsoft
cancel
Showing results for 
Search instead for 
Did you mean: 

ARC Paths in BOOT.INI

Jim Wyse
Occasional Contributor

ARC Paths in BOOT.INI

Can anyone help me decide the ARC path I need for my PC?
I have an HP Vectra XU 6/200, with the following drives:
IDE Primary Master = 4GB, Program Files, etc. ("C:")
IDE Primary Slave = 2GB, Data, Backups, etc. ("D:")
IDE Secondary Master = CD-ROM ("F:")
IDE Secondary Slave = None
SCSI ID 0: LUN 0, = 2GB, Windows 2000 System ("E:")

If I set my BIOS to boot from the SCSI, then OK.
In this case, the SCSI is drive 80h
However, I need to be able to boot from the IDE Primary Master.
On the E: drive, I have NTLDR, NTDETECT.COM, and BOOT.INI
On the C: drive, I have NTLDR, NTDETECT.COM, and BOOT.INI

Boot.ini looks like this:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional on SCSI" /fastdetect

When I set the BIOS to boot from the IDE interface, I get "cannot find %systemroot%\WINNT\SYSTEM32\ntoskrnl32." (or something along those lines)
In this case, the SCSI is Drive 82h

I have tried many and various combinations of multi(?) and rdisk(?), but cannot find the right, working combination.
I've tried the Microsoft article "Microsoft Windows XP - Reviewing and Correcting Boot.ini Settings on x86-based Systems", but I still can't figure out where I'm going wrong.
3 REPLIES
Ganesh Babu
Honored Contributor
Jim Wyse
Occasional Contributor

Re: ARC Paths in BOOT.INI

Ganesh,
Yes, I've read that, partially understood it, but still can't find the right solution.

NTBOOTDD.SYS doesn't exist anywhere on my system, so i can't use the scsi(0) method in place of the multi(0) method, if that is what is needed.
Jim Wyse
Occasional Contributor

Re: ARC Paths in BOOT.INI

OK,problem solved.
By running the Recovery Console, I was able to use the MAP ARC command.
This showed me that the correct path is:
multi(0)disk(0)rdisk(2)partition(1)

Got there in the end!