HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Audit file (disabling)

 
SOLVED
Go to solution
Joshua Gould
Advisor

Audit file (disabling)


We're doing some DR testing and trying to restore our production system that has SAN storage to a smaller test box.

The issue that I'm having is that the audit log is specified to be stored on a SAN volume that obviously no longer exists on the smaller test box.

When we boot, we get as far as the audit server starting and it hangs endlessly since it can't open the drive/file.

All the commands for either disabling auditing or specifying where the log should be written basically assume the system is already up.

How can I get around this issue?
6 REPLIES
Jim_McKinney
Honored Contributor

Re: Audit file (disabling)

Add

$ DEFINE/SYSTEM/EXECUTIVE SYS$AUDIT_SERVER_INHIBIT YES

to SYLOGICALS.COM ?
Hoff
Honored Contributor

Re: Audit file (disabling)

The same way you get around most any other bug in the startup:

http://64.223.189.234/node/204

Boot conversationally (or you can boot minimally via the STARTUP_P1 parameter, in this case) and fix the startup and the rest of the environment to not include any references to physical device names.
The Brit
Honored Contributor

Re: Audit file (disabling)


You need to define the logical name

SYS$AUDIT_SERVER_INHIBIT = "TRUE"

before startup.com runs.

Do "Minimum" boot then login and define the logical. then Spawn a subprocess and run sys$system:startup

This should get you to the point where you can log in and adjust the startup so that Auditing doesn't automatically start. Dont quote me, but I think if this logical is defined in Sylogicals then it will be effective.

Dave.
Craig A
Valued Contributor
Solution

Re: Audit file (disabling)

Or, rather than turning auditing off when not set up your environment so that it can intelligently work out which disks are availble, where, re-point the various logicals and then start Audit Server (and others) as normal.

Craig
Brad McCusker
Respected Contributor

Re: Audit file (disabling)

I'm going to 2nd what Craig said. After you solve your problem with audit, aren't you are going to run head on into other problems?

What else is not going to be available becuase the SAN isn't there?

Brad McCusker
Software Concepts International
www.sciinc.com

Brad McCusker
Software Concepts International
Wim Van den Wyngaert
Honored Contributor

Re: Audit file (disabling)

You can also delete the file sys$system:vms$audit_server.dat. It will be re-created with default settings at startup.

$ set aud/server=exit
$ del ...
$ set aud/server=start
$ set aud/server=init

and then re-apply the settings.

Wim
Wim