HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Boot from DVD hangs up

 
SOLVED
Go to solution

Boot from DVD hangs up

Hi all,

Opening new topic to continue discussion of the 'DVD boot' issue started in scope of another branch (http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1369755)

Prehistory:
We have OpenVMS V8.3-1H1 running on IA64. One physical 137Gb SCSI disk drive, mounted as one logical device, no partitioning. Also have OpenVMS 8.3 DVD for IA64. Idea is to boot from the disk as described here (http://h71000.www7.hp.com/doc/83final/ba322_90045/apbs06.html) to perform system backup (as described here http://h71000.www7.hp.com/doc/83final/ba322_90045/apes04.html?btnPrev=%AB%A0prev) to any portable USB hdd or another clear SCSI hdd.

Regular boot:
When IA64 is powered on and OpenVMS starts to boot it usually displays two warnings:
-LOADER-W-Conout device path cannot be set to multiple devices
-LOADER-I-Select Console Device Paths from the Boot Manager Menu.
then hangs up for about 5 minutes with just these two warnings and cursor blinking and then boots normally.

Boot from DVD:
If I choose EFI Shell during start up and launch bootia64.efi - the system simply hangs up with these two warnings and cursor blinking - no further boot process, no telnet/FTP to the server... It appears to be unresponsive for Ctrl+Alt+Del combination as well and can be cold booted only. I tried to wait for about 30 minutes with no progress...

I was advised to configure consoles to disable both warnings. To sum up, the system has 5 console devices:
1. Acpi(HWP0002,0)/PCI(1|1)/Uart(9600 N81)/VenMsg(PsAnsi)
2. Acpi(HWP0002,0)/PCI(1|1)/Uart(9600 N81)/VenMsg(VT100)
3. Acpi(HWP0002,0)/PCI(1|1)/Uart(9600 N81)/VenMsg(VT100+)
4. Acpi(HWP0002,0)/PCI(1|1)/Uart(9600 N81)/VenMsg(VtUtf8)
5. Acpi(HWP0002,0) /PCI(4|0)
I found out that all "Input Console", "Output Console" and "Std Error Console" used #3 and #5 devices. Console #3 appears to be a VGA display because when I turned it off for "Output console" - display was blank on next boot up and I could turn it on again only via MP console.

I left one device (#5) per each console, tried to boot DVD and got next warning "Conout device is not a UART device". Changed dev #5 to dev #3 for each console - I could boot neither DVD nor normal OpenVMS system!.. OpenVMS boot hangs up with the same symptoms as DVD boot: one record that OpenVMS is booting and cursor blinking. For about 30 minutes. Once dev #5 was turned back on for each device - OpenVMS booted quickly...

Thus I suspect that some selected/unselected devices could hang DVD boot in the same way as lack of dev#5 hangs OpenVMS boot. I will play with the settings again but not sure if it gives anything.

So any idea/input is appreciated.

Best regards,
Dmitry Sinelnikov
4 REPLIES
Steven Schweda
Honored Contributor
Solution

Re: Boot from DVD hangs up

> [...] IA64 [...]

Not a very detailed description of the
hardware. What are you using for a console
terminal, and where is it connected?

http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1365521

Re: Boot from DVD hangs up

Intel Itanium 2 chip, HP rx4640. That's basically all I know about the box. If you could tell me how to capture detailed info - I will gladly provide you with it.

As for the console - I'm using MP, connected to the client PC with standard serial cable.

Re: Boot from DVD hangs up

The issue has been resolved. I have configured MP console and disabled USB keyboard as an Input Console device (even detached it from IA64) and VGA monitor as an Output Console. Only one VT100 MP Console device was selected for each console:
2. Acpi(HWP0002,0)/PCI(1|1)/Uart(9600 N81)/VenMsg(VT100)

Eventually bootia64.efi started normally without any lockup or warn/errors.

Closing the thread. Thanks to everyone for assistance.

Re: Boot from DVD hangs up

See comments above.