HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Deleting text

 
Regina Taylor
Contributor

Deleting text

How do you delete a character or text using EDT/EVE (from pc keyboard)? I tried delete and backspace but neither worked.
7 REPLIES
Thomas Ritter
Respected Contributor

Re: Deleting text

Looks like a basic terminal emulator setup issue. I use reflection and there are options to change the behaviour of keys.
Describe your terminal emulator. Someone here will help.
Heinz W Genhart
Honored Contributor

Re: Deleting text

Hi Regina

What kind of terminal emulator are you using?
The terminal emulators offers a configuraion menu. Mostly you can find there everywhere a check box to select "VT Backspace sends" delete or backspace. I would try Delete...

Regards

Geni
Robert Gezelter
Honored Contributor

Re: Deleting text

Regina,

You do not mention which terminal emulator that is being used.

The DEL character (aka Rubout) is used to delete text. On an OpenVMS terminal configured as a CRT, this will erase the text and reposition the cursor.

- Bob Gezelter, http://www.rlgsc.com
Hoff
Honored Contributor

Re: Deleting text

This is probably a 104-key Windows-key US PC keyboard. But as other replies have indicated, what is it hooked to?

If you're on Windows, you could consider the VTstar emulator. It's available on the OpenVMS Freeware V7 distro, available via here: http://www.hp.com/go/openvms/freeware/

Another widely-used terminal emulation package is PuTTY.

If you're on Mac OS X, you can use the embedded X11 tools and related, and there are details of using ssh and X11 with OpenVMS here:
http://64.223.189.234/node/134

The same basic sequence used for Mac OS X will also operate with various of the common Linux platforms.

If you're using X Windows (DECwindows) and aiming the display somewhere with one of the various PC keyboards, tools for mapping keyboards are available from various sources, including the xterm, xkeycaps and decxterm submissions.

If the PC is hooked to an AlphaStation or AlphaServer or Integrity, you'll want to select the appropriate PC keyboard setting in the DECwindows session management menus. IIRC, the LK443 is usually the best choice here for a PC-style keyboard, though there might also be PCXAL or some similar such names for keyboards in there.

If you've got the choice, acquiring an LK464 USB (and USB to PS/2) keyboard can be a good investment. A keyboard "kit" with this keyboard and a mouse is also available.

A listing of various DIGITAL keyboards including many of those used with OpenVMS is available here (and corrections welcome):
http://64.223.189.234/node/19

Stephen Hoffman
HoffmanLabs LLC
Hein van den Heuvel
Honored Contributor

Re: Deleting text

As the others indicated, check out setups for your terminal emulator in use (PuTYY? Reflection? ..), typically under 'key board defintions'.

In the mean time, just try CNTRL-[Backspace]

Hein.


Anton van Ruitenbeek
Trusted Contributor

Re: Deleting text

Hoff,

The last time I used a USB keyboard the PF1 wasn't working fine (MS-XP, Reflection).
So I removed this one and used a PS2 aqain.
Is this normal, or did I did a mistake during configuration.
The other keys of the keypad seems to work fine but I use the EDTkeypad in EVE and actualy the PF1 is where I cant without.

AvR
NL: Meten is weten, maar je moet weten hoe te meten! - UK: Measuremets is knowledge, but you need to know how to measure !
Willem Grooters
Honored Contributor

Re: Deleting text

Not just the terminal emulator, though knowing which one is cricial.

be sure to have the BACKSPACE key to be set to DELETE and not BACKSPACE. It _should_ work. The DELETE key has a different mapping ("Remove" on a VMS-style keyboard) that does not immeduately remove the current character, only after selection of text )IIRC))

Anton:
IIRC it's the combination of the chip in the keyboard, with the decoder in the box that can give this kind of problems. The hardcoded one hooked to the PS2 keyboard port does the translation properly, the one in the software to handle the USB port doesn't.
FWIH, this is the same issue with LK400-type keyboards hooked to a PC. On PS2 + the right driver, it works. With USB, it won't. (it can be the driver needs an aupdate for that).
Willem Grooters
OpenVMS Developer & System Manager