Operating System - OpenVMS

ECP analyze display error

Go to solution
Jan Andersson_3
Occasional Advisor

ECP analyze display error



I have installed TDC 2.3-20 on VMS 8.4 and tried to analyze performance, but I get an error.


GRIPEN> plan analyze/motif
 Enterprise Capacity Performance Analyzer (c) 1997, 2006 Hewlett-Packard Develop ment Company, L.P., All Rights Reserved.
 gripen$dka0:[sys0.syscommon.][sysexe]ecp$analyze_motif.exe;1:  Can't open display

GRIPEN> mc decw$puzzle .     !  Works ok.

I also directed the output to my PC:

SET DISPLAY/CREATE/TRANSPORT=TCPIP/NODE=axdt0608.samba.net  gave the same error and decw$puzzle works.


Tried the following with the same result:

Availibility Manager command avail/analyze works with the display on my PC.

It can also start a display on my workstation but that only starts an all grey window with no lines or columns in it.

But that is another problem.


Any clue?


Regard Jan Andersson

John Gillings
Honored Contributor

Re: ECP analyze display error



   Very odd! I get a display from OpenVMS/Alpha V8.4 running ECP$ANALYZE_MOTIF version:


                image name: "DI_MOTIF"
                image file identification: "ECP V5.6A-30"
                image file build identification: ""
                link date/time: 23-MAY-2006 13:48:07.51
                linker identification: "A13-03"


with the display using /TRANSPORT=TCPIP pointing to a PC running ReflectionX


If your display is the local node, you should be using SET DISPLAY/TRANSPORT=LOCAL/NODE=YOURNODE.


Maybe there's a quota issue which is preventing the display from opening? My quotas for a subprocess running ECP$ANALYZE_MOTIF look like this (SHOW PROCESS/CONTINUOUS/ID=pid then hit Q):


    # open files remaining                97/100                  ( 97%)
    Direct I/O count/limit               150/150                  (100%)
    Buffered I/O count/limit             149/150                  ( 99%)
    BUFIO byte count/limit            296544/296672               ( 99%)
    ASTs remaining                       995/1000                 ( 99%)
    Timer entries remaining              199/200                  ( 99%)
    PGFL quota count/limit             29929/31250                ( 95%)
    ENQ quota count/limit               4996/5000                 ( 99%)

 Nothing spectacular, but maybe worth checking.


Unfortunately the secondary error, which would tell you WHY the display can't be opened has been omitted by the programmer. A long shot, check $STATUS immediately after the failed command, maybe that has more information?


Please log a case with your local customer support centre, as well as assisting you, they should send feedback to engineering to fix their error reporting!

A crucible of informative mistakes
Jan Andersson_3
Occasional Advisor

Re: ECP analyze display error

As my ds10 workstation has became a bit messed up, I did a clean VMS install of 8.4.

Trying to install ECP fails.


        Beginning installation of VECP0 V56.A at 12:53

%VMSINSTAL-E-EXPIRED, This product has expired after OpenVMS Alpha version 8.3 %VMSINSTAL-E-EXPIRED, Please contact your local hp sales representative %VECP0-E-UNSUPVMSVER, Installation of this kit on this version of OpenVMS is not  supported.
%VMSINSTAL-E-INSFAIL, The installation of VECP0 V56.A has failed.

Earlier I had ECP installed before the upgrade to VMS 8.4.

Maybe it just don't run on VMS 8.4 even thogh it is an Alpha.

I know it's not for Itanium but theres nothing said about Alpha.



Volker Halle
Honored Contributor

Re: ECP analyze display error



do you have to happen a symbol named DISPLAY defined in your process ? That would be one possible cause for the problem you're describing. For some reason, the DECwindows routines seem to try a symbol with that name when creating the display.



Jan Andersson_3
Occasional Advisor

Re: ECP analyze display error

Yes, I had a DIS*PLAY symbol, but nomore.
Now it's working!!
Thanks a lot Volker.
Now I just have to install it on VMS 8.3 and then upgrade to 8.4 to see if it still works.
paul o'sullivan_1
New Member

Re: ECP analyze display error

To identify a network problem, rather than an ECP problem, run an ecp comand line


plan analyze/beg=/end=/node=nodename


I use the ported ECP