Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Error when attepting to compile object

SOLVED
Go to solution
Robert Manning_2
Valued Contributor

Error when attepting to compile object

Hi,

I have an application support team who are encountering problems when trying to compile an object, ostensibly for an Oracle application.

The error message returned by their process refers to a missing image file, ORA_UPISHRV7.EXE, and the process quits.

**** **** **** **** **** ****
building util_pc.obj
%DCL-W-ACTIMAGE, error activating image ORA_UPISHRV7
-CLI-E-IMAGEFNF, image file not found $1$DKB0:[SYS0.SYSCOMMON.][SYSLIB]ORA_UPISHRV7.EXE;
**** **** **** **** **** ****

I need to find and install a copy of this image, but I'm uncertain whether it's an Oracle image or something I could expect to find in a VMS library. I've searched the web but can find no references to it anywhere.

My questions, therefore, are three:

1 - does anyone know what this image is?

2 - if so, can it be used by itself or is there a wider group of images upon which it may depend?

3 - where am I likely to find it?

I should further explain that the application in question is an Oracle 7.1.5 database sitting on OpenVMS Alpha 6.2-1H3. It was migrated from an older system which was then decommissioned, and the retention period for backups has since expired...

If anyone had any ideas or advice, I'd appreciate it...

Thanks,

Bob
10 REPLIES
Kris Clippeleyr
Honored Contributor

Re: Error when attepting to compile object

Robert,

Knowing next to nothing about Oracle, but guessing by the filename ( ORA_UPISHRV7 ), I think that "build" tool somehow invokes an image that wants to activate the shareable image ORA_UPISHRV7.
Could you scan your disks for a file called ORA_UPISHRV7.EXE, and then define a logical ( ORA_UPISHRV7 ) that translates to that file, and try again?
If you can't find the file, I think your outta luck.
Good hunting,
Kris (aka Qkcl)
I'm gonna hit the highway like a battering ram on a silver-black phantom bike...
Duncan Morris
Honored Contributor

Re: Error when attepting to compile object

Hi Bob,

This is an Oracle V7 shareable image.
Look for it in ORA_UTIL.

On my V7.3.4.4 tree it is found here:

DRA3:[ORA7344.UTIL]UPISHRV7344.EXE

The final portion of the filename depends upon the value given by your site to this particular Oracle tree. In my case I used V7344 as the identifier, and it looks at though your site used V7.

Linking of Oracle based programs should make use of specific oracle link command procedures. If you have your own custom system, then ensure that you point to all the libraries etc that are shown in the appropriate ln*.com

On my system I have...

DRA3:[ORA7344.PROGINT.EXE]LNPROC.COM

DRA3:[ORA7344.PROGINT.EXE]LNPROCOB.COM

etc
Steven Schweda
Honored Contributor

Re: Error when attepting to compile object

It sure looks Oracle-related, not part of
VMS. (VMS stuff would typically have a "$"
in the name, not (only) an "_".)

1 - Not I.

2 - No idea.

3 - Apparently not in SYS$LIBRARY. You could
try "DIRE disk:[000000...]ORA_UPISHRV7" for
all your "disk:" devices.

Could it have been a logical name which
pointed to some real file or directory?
(Look for "*UPI*"?)

Google found slightly more than nothing on a
search for (plain) UPISHR. Perhaps some less
public Oracle documentation would be more
informative.
Volker Halle
Honored Contributor

Re: Error when attepting to compile object

Bob,

ask Oracle...

I've found logicals named ORA_UPISHR* pointing to UPI*.EXE images in [ORACLE7.UTIL] and [ORACLE7.RDBMS] directories at a customer site running 7.3.2. There is a LUPISHR.COM DCL procedure in the [.UTILS] dir, which says: Link UPI shareable image

Maybe you're just missing a logical ORA_UPISHRV7 pointing to the right image ?

Volker.
Duncan Morris
Honored Contributor

Re: Error when attepting to compile object

A couple of further points (as I remember my older Oracle versions!)

1) there should be a logical ORA_UPISHRxxx (where xxx is system ident, V7 in your case)
The fact that your build is looking in SYS$SHARE would tend to imply that the logical has not been defined. Had the Oracle 7.1.5 system not been started at the time of the compilation?

2) the ln(lang).com routines are really just front ends to the real business end of the Oracle linkage routine ora_util:loutl.com

Here is a snippet from my own "build" routine for PRO/C modules

$!
$ ORACLE_LINK:
$ WS "Linking", DEBUG_LINK_QUAL, MAP_QUAL, "..."
$ ORA_OPT = ""
$ IF MAP_QUAL .EQS. "/MAP" THEN ORA_OPT = ORA_OPT + "M"
$ IF DEBUG_LINK_QUAL .EQS. "/DEB" THEN ORA_OPT = ORA_OPT + "D"
$ shared_sql_lib == "YES"
$ lnproc 'FILE_NAME -
'FILE_NAME,DEV_DIR:ORA_FUNCTIONS.OPT/OPT -
'ORA_OPT
$

Robert Manning_2
Valued Contributor

Re: Error when attepting to compile object

Thanks, guys,

I've since found a logical pointing to a file that might fit the bill,

"ORA_UPISHRV715" = "$1$DKA100:[ORACLE.RDBMS]UPISHRV715.EXE"

which would have been installed for use by another application. It appears to be okay, ANALYZE showed no problems with it

So I imagine my apps guys just have to rewrite their procedure to use the new logical and that should sort them out?

Or would that be too simple?

Bob
Duncan Morris
Honored Contributor
Solution

Re: Error when attepting to compile object

Bob,

that logical would suggest that the identifier on this system is V715, whilst it was V7 on the old system.

If you can get the build procedure changed to use V715 throughout instead of V7, then it should be OK.

If you need to stick to V7, then define ORA_UPI_SHRV7 to point to the V715 image.

Duncan
Robert Manning_2
Valued Contributor

Re: Error when attepting to compile object

Duncan,

Yep, that seems to have worked - the user's process can now see the libraries and it looks like the compiler's working for them.

They've come up against some other error but it's an internal Oracle issue that they're going to follow up by themselves.

Thanks to everyone for the input - much appreciated...

Bob
Daniel Fernandez Illan
Trusted Contributor

Re: Error when attepting to compile object

Bob

Generally, the images to install of ORACLE applications are in M_RDBMS:[DBMS]INSORACLE.COM

This command file assign logicals names to executable images and execute (for ORACLE v7)
M_RDBMS:[RDBMS]INSLIBS.COM to install LIBRARIES.

Saludos.
Daniel.
Robert Manning_2
Valued Contributor

Re: Error when attepting to compile object

Creation of user-specific logicals to point to the installed libraries seems to have worked, and my colleagues are happy to chase down any remaining issues by themselves.