Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Force request to input date and time on system boot - OpenVMS Alpha

SOLVED
Go to solution
A.W.R
Frequent Advisor

Force request to input date and time on system boot - OpenVMS Alpha

Hi,

On the Alpha with the OpenVMS operating system is it possible to force the system to request the date and time when the system boots rather than waiting for the boot to complete, and then changing it?

Thanks
Andrew
5 REPLIES
Kris Clippeleyr
Honored Contributor
Solution

Re: Force request to input date and time on system boot - OpenVMS Alpha

Andrew,

Try booting "conversational" ( >>> boot -fl 0,1 ); and at the SYSBOOT> prompt, change the system parameter SETTIME to 1, and continue.

Don't forget to set the parameter to 0 again or else the system will ask for the date/time with every boot.

Regards,
Kris (aka Qkcl)
I'm gonna hit the highway like a battering ram on a silver-black phantom bike...
John Gillings
Honored Contributor

Re: Force request to input date and time on system boot - OpenVMS Alpha

Andrew,

Normally the hardware clock is adequate for keeping track of system time. Is there an issue with the way the time is being set? Is it wrong? Make sure you issue a privileged SET TIME command (no parameters) at least once a year, before April.

There are some rather ugly aspects to the way OpenVMS determines the time at boot, which can result in the wrong time being set. Once you understand the limitations it's fairly easy to do all the things to keep the time correct, but otherwise you can get some highly counter-intuitive results.

I'm not sure if you're asking about a one-off or you want this to happen every time you boot.

As Kris pointed out SETTIME enables or disables prompting:

SYSGEN> HELP SYS SETTIME

Sys_Parameters

SETTIME

SETTIME enables (1) or disables (0) solicitation of the time of day each time the system is booted. This parameter should usually be off (0), so that the system sets the time of day at boot time to the value of the processor time-of-day register. You can reset the time after the system is up with the DCL command SET TIME (see the HP OpenVMS DCL Dictionary).


Also be aware of TIMEPROMPTWAIT, which controls how long the system will wait.

SYSGEN> HELP SYS TIMEPROMPTWAIT

Sys_Parameters

TIMEPROMPTWAIT

TIMEPROMPTWAIT defines the number of seconds that you want a processor to wait for the time and date to be entered when a system boot occurs, if the processor's time-of-year clock does not contain a valid time. (The time unit of micro-fortnights is approximated as seconds in the implementation.) If the time specified by TIMEPROMPTWAIT elapses, the system continues the boot operation, and the date and time are set to the last recorded time that the system booted.

(see your system for further details)

A crucible of informative mistakes
Hoff
Honored Contributor

Re: Force request to input date and time on system boot - OpenVMS Alpha

And if you'd like to skip the manual processes involved here and jump right to the current date, see the ntpdate discussion here: http://labs.hoffmanlabs.com/node/1280
A.W.R
Frequent Advisor

Re: Force request to input date and time on system boot - OpenVMS Alpha

THanks for the prompt an comprehensive responses.
Kevin Raven (UK)
Frequent Advisor

Re: Force request to input date and time on system boot - OpenVMS Alpha

I remember a few years ago ...well 12 years ago :-) ....I booted a VAX cluster (4 nodes) that run ALL-IN-1 (spelling? I used to know the brand name correctly , but age makes me forget). Simple task ...dial in from home at 8pm and reboot cluster.
Kicked of reboots and went for a coffee.
Came back to VT320 and watched the boot(s) via connecting to consoles via VCS ...seemed to be taking forever to boot and looked like they had all hung during boot.
Oh joy ...as I saw the year had advanced to next year !!!!!
We set logins during boot , so you could connect and watch the STARTUP process etc run ...
Thus all the batch jobs that were due to run had kicked off ..that would be every batch job !
Including one that archived all old mail messages that were in peoples inbox that were over 1 year old ...so with the date now being set to 1 year ahead ...that was every e-mail in the inbox...
Got to CTRL_P the 4 servers just in time ...only 20 people out of a possible 2,000 + mailbox were hit.

It turned out to be a bug in VMS ...where if you run DTSS ...you needed to disable it and set the time via SET TIME once per year by hand.

This is where my love affair with OpenVMS hit a rocky patch.