Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

How to have only one ucx$ftpd.log file?

SOLVED
Go to solution
Andreas Fassl
Frequent Advisor

How to have only one ucx$ftpd.log file?

Hi there,

the system I'm seeking help/advice for is fixed to OpenVMS release V7.1 and UCX Release 4.1 ECO 10.
Some data gets transferred via FTP on a regular basis (5 minutes), so the number of ucx$ftpd.log files is getting a problem.
How can I disable the creation of this logfile, browsing through the docs didn't give enlightment. The command "set file/version" wasn't helpful, too.

Looking forward for some help,

best regards

Andreas
4 REPLIES
Volker Halle
Honored Contributor
Solution

Re: How to have only one ucx$ftpd.log file?

Andreas,

you can try to increase the FTPD idle timeout by setting the UCX$FTPD_IDLETIMEOUT

Don't know whether that will work on UCX V4.1. But you can check the creation and modification time of the UCX$FTPD.LOG files and guess, what the value of the idle time may be.

You could also try to increase the inactivity timer with UCX SET SERVICE FTP/INACTIVITY=10 (need to stop and start the FTP service afterwards).

This should cause the UCX$FTPD process to stay up longer and create logfiles less often. But don't bet that these mechanisms will work for UCX V4.1.

And you can also suppress the creation of new UCX$FTPD.LOG files by creating a file with UCX$FTPD.LOG;32767 see

http://h71000.www7.hp.com/wizard/wiz_5964.html

Volker.

Jan van den Ende
Honored Contributor

Re: How to have only one ucx$ftpd.log file?

Andreas,

like Volker wrote, you can suppress creation.

If however you have a desire/need to keep them (for review or debug puprposes maybe?)
then you can collect all of them in on per day by adingd something to the FTPD LOGIN.COM like
$this_day = F$CVTIME(,,"date") - "-" - "-"
$appendloop:
$ oldfile = f$search("UCX$FTPD.LOG;1")
$ if oldfile .nes. ""
$ then
$ append/new 'oldfile' UCX$FTPD.'this_day'
$ delete 'oldfile'
$ goto appendloop
$ else !any old ones gone now
$ rename UCX$FTPD.LOG;0 ;1
$ endif

-- sorry, intended indentation murdered by forum formatting
-- this is the functionality only, please DO add the necessary robustness testing!


hth

Proost.

Have one on me (perhaps in May in Nashua?)

jpe
Don't rust yours pelled jacker to fine doll missed aches.
Volker Halle
Honored Contributor

Re: How to have only one ucx$ftpd.log file?

Andreas,

UCX SET SERV FTP/INACTIVITY=12 (default was 5) with a subsequent re-enable of the FTP service seems to increase the UCX$FTPD idle time from 10 to 24 minutes (on UCX V4.2 ECO 1) - so it may be worth a try on V4.1 as well.

Volker.
Andreas Fassl
Frequent Advisor

Re: How to have only one ucx$ftpd.log file?

Great help!!!

Thank you so much.