HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Job aparently freezze

 
SOLVED
Go to solution
Roberto dAvila
Occasional Contributor

Job aparently freezze

There is a job on my Openvms 7.1-2 that executes a backup to tape. This backup usually need 3 tapes and, just after I put the third tape the process "freeze". There is no change in cpu, io, page faults, etc. Also, there is no error message and I have to stop the process.
Does anybody have an idea? Very thanks
13 REPLIES
Hoff
Honored Contributor

Re: Job aparently freezze

Did the batch job (simply) finish here?

What are the commands involved?

Have you tried the BACKUP command sequence interactively?

What state (rwast?) is the process in when this happens?

Are the process quotas for the username running BACKUP set per the HP recommendations?

Do you have the patches for V7.1-2 loaded?

What has changed here?

Are any device errors logged?

Does having an operator enabled (REPLY /ENABLE) show any messages when the processing wedges?

Tried this with fresh tape media?

What's changed here?
Andy Bustamante
Honored Contributor

Re: Job aparently freezze

What is the exact backup command please. What logs are generated by this job. Are the tapes labeled appropriately if required? Second Hoff's question, are there any operator messages queued?

If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Shriniketan Bhagwat
Trusted Contributor

Re: Job aparently freezze

Hi,

What does â process freezeâ mean?
Does that mean backup is not happening on third tape? Check the tape labels. If you are not concerned about the exact tape label, you can use /IGNORE=LABEL_PROCESSING qualifier. If you are concerned about the exact tape label use /EXACT_ORDER qualifier. Use /LOG qualifier in the BACKUP command. This will indicate whether the BACKUP is able to backup any files on to third tape or not.

Regards,
Ketan
Bob Blunt
Respected Contributor

Re: Job aparently freezze

Right, job status is crucial here. $ SHOW PROC/CONT/ID=pid and look at the PC and counters to see if they're changing. Check the active image for the process.

I usually don't say this often but V7.1-2 is somewhat aged. Is there a compelling reason for staying on that version and have the most recent patches (relatively speaking) been applied?

Knowing the BACKUP command string could help and the way that command is issued might also be interesting. Batch or interactive? Part of a BACKUP menu script? Part of either SLS or ABS? Seems to me that there might have been some issues with BACKUP "getting lost" during processing around the V7.1-2 timeframe, too. The utility has changed a LOT since then. BACKUP patches could be a necessity...

bob
Volker Halle
Honored Contributor
Solution

Re: Job aparently freezze

Roberto,

welcome to the OpenVMS ITRC forum.

If none of the previous requests for information has helped you diagnose your backup problem, please consider to use SDA to find out more information about the state of your BACKUP process:

$ ANAL/SYS
SDA> SET PROC/ID=
SDA> SHOW PROC
SDA >SHOW PROC/CHAN ! look for busy channels
SDA> SHOW PROC/LOCK ! look for waiting locks
SDA> EXIT

Consider to provide the output in an attached .TXT file to your next reply.

Volker.

Roberto dAvila
Occasional Contributor

Re: Job aparently freezze

Anwsering all of you:
- The command is:
$ Backup -
/BLOCK_SIZE=32255 /log /List
/Ignore=(InterLock,Label)/Media=Compac -
sngs_pro.rbf; mka600:sngsbkp.1904 /Save
- It usually takes 6 hours so it runs in batch
- The job state is LEF
- In the Show proc/cont NOTHING changes, except time (top right)
- Quotas: the job runs under system account
In the beginning 1 tape was enough, now we use tree tapes...
Sometimes the job finish ok, other times it freezes.
- No patches were load on OpenVMS 7.1-2
- There are no errors reported
- Operators use Reply/enable and receive the solicitation
to put a new tape
- I use new medias
- SDA: I will wait next "freeze occurrency" to use SDA.

I hope the information above can better clear the scenario.
Thank you all
Andy Bustamante
Honored Contributor

Re: Job aparently freezze

The /log lists the files as processed, the /list is to provide a directory listing of the files in a save set. Remove the /list qualifier.

Based on the file name, I'll make the assumption that you're backing up an Oracle RDB backup file. Ignore the following if that's not correct.

When the backup job starts, the file should be completely written, so you don't need INTERLOCK in the /ignore qualifier. Can you confirm the RMAN process to write this file has completed when the backup is started?

If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Roberto dAvila
Occasional Contributor

Re: Job aparently freezze

Andy,
- /list qualifier will be removed
- /ignore=interlock will be removed
- The only file being backed up is really a Oracle RDB. We use Rmu/backup command to make a disk backup of our database and after that we make a OpenVMS backup to put the first backup on a tape. The first backup has certainly finished before the second starts.

The last five executions of backup routine ran fine (???).
I suppose that there are external reasons affecting backup job (like another job or user process), and I'll be care abaout.
The intriguing about this is that the system does not return anything. It just freezes...
Volker Halle
Honored Contributor

Re: Job aparently freezze

Roberto,

may I also suggest, that you add the /REWIND qualifier to your backup command. This makes sure, that the backup actually starts at the beginning of the first tape. If NOT using /REWIND (note: /NOREWIND is the default !), backup would skip over all existing savesets on the tape and start writing your saveset after the last saveset found on tape.

Volker.

Jon Pinkley
Honored Contributor

Re: Job aparently freezze

Roberto,

As Volker suggested, use the /REWIND qualifier. Since this backup is taking multiple tapes anyway, I can't think of any reason to append to any previous tape. Also, without it the use of /media=compaction will be ignored (at least for the first tape).

You stated you are using new media. I would expect that to work, but there may have been some bugs with backup from 7.1-2 with continuation volumes not being initialized. See $help backup /label for a description of what Backup will do if a label isn't specified.

Try this:

1. Before backup starts, initialize your tapes, each with a unique 6-character label (I would also put a paper label with that label printed in the slot in the tape cartridge. (What type of tape drive is this? DLT, DAT, something else? Please specify model number). The output of show device/full mka600: should provide a clue (at least in VMS versions from the last 10 years or so, I am not sure if 7.1-2 did).

2. In the backup command, use /LABEL=(label1,label2,label3)/exact_order/rewind [/tape_expiration=date] [/media_format=compaction] [/protect=(S:RWED,...)]. The combination of /label and /exact_order causes VMS BACKUP to verify that the correct tapes are used, and that all 6 characters of the label are significant. This prevents mistakes, like putting the same tape back into the drive and overwriting it with a continuation volume. /TAPE_EXPIRATION allows you to specify a date that you want to save the tape until, before allowing BACKUP to overwrite it. (This is a blade guard, and can be overridden). The /media_format /protect and /density are used when initializing and rewriting the tape headers.


3. I would use /BLOCKSIZE=32256 or 31744 instead of 32255 (which will be rounded down to the previous multiple of 512, or 31,744). This is just so the qualifier is consistent with the actual value that is used.

4. If you use list, I would recommend having it go to a file. I.e. /list=backup_lst:sngsbkp_1904.lis There is no problem with using /list while the backup is being made. Since this backup will have

5. /SAVE is default for tape save sets, but specifying it definitely causes no harm, and removes any doubt as to what is being written.

Example:

$! init tapes. This only has to be done the first time you use a tape (and define its tape label)
$! put in second tape
$ init mka300: rbf002 /own=system /prot=(s:rwed,o:rwed,g,w) /media=compaction
$! put in third tape
$ init mka300: rbf003 /own=system /prot=(s:rwed,o:rwed,g,w) /media=compaction
$! put in first tape
$ init mka300: rbf001 /own=system /prot=(s:rwed,o:rwed,g,w) /media=compaction
$
$! now do the backup...
$
$ Backup -
/BLOCK_SIZE=32256 /log /List=sngsbkp_1904.lis /rewind -
/Media=Compact /label=(rbf001,rbf002,rbf003) /exact_order -
sngs_pro.rbf; mka600:sngsbkp.1904 /Save /tape_expiration=1-jan-2011 ! example of tape_expiration

Jon
it depends
John McL
Trusted Contributor

Re: Job aparently freezze

I don't see an answer to Hoff's question about whether any hardware errors are being logged.

A hardware problem with a tape drive can ruin your whole day.

Also check that all cables to your tape drive are seated properly. The fact that the backup runs sometimes but not others is curious, so we need to look for possible intermittent faults.
Roberto dAvila
Occasional Contributor

Re: Job aparently freezze

Thank you guys!
I think that there are enough hints to hold this problem so I'm closing this thread.
Roberto dAvila
Occasional Contributor

Re: Job aparently freezze

The problem was fixed, so I'm closing the thread