Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Mon Disk/Item=Queue Keeps going up?

Mike Hellier
Occasional Visitor

Mon Disk/Item=Queue Keeps going up?

Using a DS20E, running VMS 7.2...

Disk3 in a SAN volume shadow set (on HSG80 as a mirrored stripeset) has an io request queue length that just keeps going up and up.

I'm not a sysadmin (this box doesn't appear to have one) but like to keep an eye on things - so to see the current value get to 400,000 (over a period of months) was a bit weird to say the least.

Last weekend I rebooted the box and ever since the values have continued to increment.

Anybody have any ideas? This is a quiet disk with very little on it or happening with it so I can't explain it.
6 REPLIES
Duncan Morris
Honored Contributor

Re: Mon Disk/Item=Queue Keeps going up?

Hi Mike,

Welcome to the ITRC OpenVMS Forum!

Exactly which version of V7.2 do you have? The release notes for OpenVMS VMS722_F11X-V0100 Alpha V7.2-2 will probably be relevant.

"On Multi-Path devices, a MONITOR DISK/ITEM=QUEUE_LENGTh
command will show a high queue length. It will stay high
until reboot. The queue length on a switched path device, as
seen from SDA, will show as negative. "

Mike Hellier
Occasional Visitor

Re: Mon Disk/Item=Queue Keeps going up?

Hi

We're on 7.2.1h1 if memory serves me right with a volume show set based in a pair of mirrored RA800's with twin HSG80's. Three logical disks in each (all mirrored stripesets).

I'm the application designer so bear with my lack of VMS knowledge, I do have some but it tends to be fragmented...

The thing that I find strange is that the other two logical disks run perfectly normally, disk 1 is a mirror pair for the O/S, disk 2 contains the main application and is fairly busy with disk 3 being a history disk.

Basically disk 1/2 don't show any waiting i/o's (<0.5) as an average but disk 3 now shows 6509 and the box was rebooted last weekend.

Thats the thing I find inconsistent - why should one disk in the array/RA8000 show such a difference and why should it keep incrementing.

Happy with VMS by the way, have been using it for years and its been terrifically stable - also pretty happy with the Alpha's and OVMS.
Duncan Morris
Honored Contributor

Re: Mon Disk/Item=Queue Keeps going up?

If I remember rightly, the queue length issue used to pop up randomly. Some disks would show good counts, whilst other went into this ever increasing value. We applied the patch once it came out, as it was mucking up our reporting tools at the time.

Your correct patch would be:

VMS721H1_F11X-V0200

Mike Hellier
Occasional Visitor

Re: Mon Disk/Item=Queue Keeps going up?

Thanks Duncan, will research the fix and propose it to the system owners.
Volker Halle
Honored Contributor

Re: Mon Disk/Item=Queue Keeps going up?

Mike,

welcome to the OpenVMS ITRC forum !

This is 'just a software error' where the QLEN field is decremented in the wrong UCB for a multipathed device, so the 'other' path UCB will not get it's QLEN count decremented and the value will raise continously. Nothing to worry about ;-)

For V7.2-1H1 (check with $ SHO SYS/NOPROC if you really are running this version), the fix is in VMS721H1_F11X-V0200

Volker.
Mike Hellier
Occasional Visitor

Re: Mon Disk/Item=Queue Keeps going up?

Duncans suggestion was correct..

The patch is supposed to fix this fault and I do know that some patches were lost on this machine some time ago.

So it seems reasonable that the lost patches need to be reinstalled.

Thanks for the swift resolution, this has been driving me mad..