Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS Backup error

Jesus Nieto_1
Occasional Visitor

OpenVMS Backup error

Hi:
I am having the next output for the command:
$ backup/log file.txt file.bck/sav

%SYSTEM-F-ACCVIO, access violation, reason mask=04, virtual address=000000007AED
C418, PC=00000000000F4908, PS=0000001B

Improperly handled condition, image exit forced.
...

In a satellite node (7.2-1h1) connected to a cluster system with the same OS version.
The weird is that I have six satellites nodes and this is only happen in two of them.
All these nodes have the same OS, and patches.
Also the command do not fail if I send the data to a magnetic tape.

Regards
6 REPLIES
Peter Zeiszler
Trusted Contributor

Re: OpenVMS Backup error

%SYSTEM-F-ACCVIO, access violation = tried to access a memory location and was denied.

mask 04 == write function

Do you have permissions to write to the location in question?
Have you tried
backup/ignore=interlock file.txt -
file_test.bck/save
David B Sneddon
Honored Contributor

Re: OpenVMS Backup error

Are you using a common UAF?
Are the SYSGEN parameters the same on all the
satellites?
Try increasing the PGFLQUOTA value for the systems
experiencing the problems.

Dave
John Gillings
Honored Contributor

Re: OpenVMS Backup error

Jesus,

Does this happen for any BACKUP command? Is the file particularly large? Could be a quota issue. See the BACKUP manual for recommended quotas.

It could also be a corrupt image, or global section.

If this is a common system disk, try:

$ DEFINE BACKUP SYS$SYSTEM:BACKUP.EXE;

and repeat the command. This will bypass the installed image. If the behaviour changes, have the system manager execute:

$ INSTALL REMOVE BACKUP
$ INSTALL ADD BACKUP

If it's not a common system disk see if the BACKUP image is different from those on other nodes.

Also check for device errors.
A crucible of informative mistakes
David Jones_21
Trusted Contributor

Re: OpenVMS Backup error

Getting any improperly handled condition from backup should be considered a bug and reported to HP.

Sounds like it is not checking for allocation failure and using an invalid pointer. Try using /blocksize=8192 and see if the virtual address changes from 7AED.
I'm looking for marbles all day long.
Jesus Nieto_1
Occasional Visitor

Re: OpenVMS Backup error

Thank you very much to all of your kindly answers.

Let me give you my feed back:

Peter:
Yes I have permissions to write in all the disks, also my account have bypass privilege.
Yes I did tried /interlock qualifier.

David:
Yes the sysuaf data files is common to the whole cluster.
Yes I did tryed to icrease the pgflquo.
The values I have in the account are:
wsdef: 512000
wsquo: 512000
wsextent: 655360
pgflquo: 655360

John:
No until I found only happens with the qualifier /Save.
Yes, I have tried define the backup command, but it did not work.
I have verified the images, and they are the same. (0 differences)
The images are well installed with the INSTALL utility.
Jesus Nieto_1
Occasional Visitor

Re: OpenVMS Backup error

Thanks David:

I have not tried to contact HP yet, I am trying to do a research by my self.
Because I found really weird this issue.

Regards.