Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS E8.2 - problem with DECC$SHR_EV56

AlNa
Occasional Advisor

OpenVMS E8.2 - problem with DECC$SHR_EV56

Need you help please.

I installed Websphere 6.0 on OpenVMS E8.2 (Alpha)

When try to start it i get error

%IMGACT-F-SYMVECMIS, shareable image symbol vector table mismatch

-IMGACT-F-FIXUPERR, error when MQZ_64 referenced DECC$SHR_EV56

 

I try to update the latest patches to OS, but i face problem that patches for 8.2 is not suitable for E8.2!

 

 

%PCSI-E-APPLYTOERR, maintenance product DEC AXPVMS VMS82A_ACRTL V4.0 applies to
a product that is not installed
-PCSI-E-APPLYTOPRD, prerequisite product is DEC AXPVMS VMS V8.2
%PCSI-E-S_OPFAIL, operation failed
%PCSIUI-E-ABORT, operation terminated due to an unrecoverable error condition

 

WHt should i do?

 

2 REPLIES
Hein van den Heuvel
Honored Contributor

Re: OpenVMS E8.2 - problem with DECC$SHR_EV56

"prerequisite product is DEC AXPVMS VMS V8.2"   That's pretty clear huh?


>>  OpenVMS E8.2 

Best I know E8.2 was a FIELD TEST version for OpenVMS version 8.2.

That fieldtest ended many years ago and all its users should have moved to V8.2 at that point.

If you use a fieldtest version beyond the target release you are 'on your own'.

 

OpemVMS 8.2 ended up being very little used and has long long sinces been replaced by OpenVMS 8.3

More recently (2 years?)  that was superceded by OpenVMS 8.4 which is seeing good adoption now notably on Itanium (required for latest blades).

 

You should first and foremore attempt to get of this fieldtest version onto V8.3 (with patches) at least.

Possibly plough ahead to 8.4 (also with patches) while changes are being made and validation/certificaiton is happening. Skip V8.2

Any other effort is a waste of time IMHO.

 

Regards,

Hein. 

H.Becker
Honored Contributor

Re: OpenVMS E8.2 - problem with DECC$SHR_EV56

Hein said it all.  So I can only play your flashlight in the dark.
 
DECC$SHR[_EV56] does not contain a useful match control, it has major id: %X'01', minor id: %X'000001' and MATLEQ even on current systems. (Whether one should use match control or not is a discussion I don't want to start and/or contribute.)
 
So the error tells you that MQZ_64 is linked against a CRTL with a different (longer) symbol vector, aka different (bigger) set of exported symbols and very likely a different/enhanced set of features, AND that MQZ_64 has a reference into the added section of the symbol vector. That is, MQZ_64 makes use of at least one of the additional features.
 
Whether there was a feature addition to the CRTL between E8.2 and V8.2  escapes me. Usually a field test version is feature complete. I'm sure IBM says, you should apply recent patches and they are not (and don't want to be) specific about an added feature of the CRTL, which they require. Sure, if you have time, then you can play games and try to get hold of the real or a (recently) patched CRTL for V8.2. Yes, you were almost there, but couldn't or didn't want to extract and use just the image file from the kit. Probablilities are in the medium to high range that it will work. But, with a medium to low probability it may have a reference to another real or (recently) patched shareable image and you may see the same error or a SHRIDMISMAT for [an]other image[s]. Which brings the light back to Hein: get a more recent, fully patched version of VMS installed on the system.