Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS no inbound ftp

 
SOLVED
Go to solution

OpenVMS no inbound ftp

FTP client & server are enabled & started,
but:
TCPIP> sho serv ftp

Service Port Proto Process Address State

FTP 21 TCP TCPIP$FTP 0.0.0.0 Disabled
TCPIP>

Even so, we can use outbound FTP to transfer files to other machines on the network, but
all attempts to connect to this host for FTP are rejected.
What are we overlooking?
29 REPLIES 29
Robert Gezelter
Honored Contributor

Re: OpenVMS no inbound ftp

Roger,

First of all, inbound and outbound are completely separate, except for the fact that both use the underlying IP stack.

Are there any error messages when the FTP server is started? Are the correct processes up and running? Are the accounts used by the underlying FTP server in proper order?

It is rather difficult to diagnose "over the phone" with information that is so limited.

- Bob Gezelter, http://www.rlgsc.com

Re: OpenVMS no inbound ftp

We have lost a lot of sys admin experience recently.

1) No error messages except when external machine tries to connect: connection rejected.

2) Which specific "correct processes" should we look for to be "up and running"?

3) Which accounts are "used by the underlying FTP server"?
Robert Gezelter
Honored Contributor

Re: OpenVMS no inbound ftp

Roger,

For a start, which IP stack (and which version) are you running?

- Bob Gezelter, http://www.rlgsc.com
Homer Shoemaker
Frequent Advisor

Re: OpenVMS no inbound ftp

I don't know what system you're using, but it looks like the FTP service is Disabled.

If that's so, maybe this will help.

From the $ prompt:

@SYS$MANAGER:TCPIP$CONFIG

Select Server Components

Select the option to enable FTP

Re: OpenVMS no inbound ftp

Welcome to OpenVMS (TM) Alpha Operating System, Version V7.3-2

See attch.
John Gillings
Honored Contributor

Re: OpenVMS no inbound ftp

Roger,

Some dumb questions...

1) are you sure the requesting node has the correct address mapping? Try telnet and make sure you're reaching the right node.

2) See if you can FTP to yourself

3) Check your limits with $ TCPIP SHOW SERVICE FTP/FULL

4) Check for log files (see "File:" in the SHOW SERVICE output from 3)

5) Enable full login and logfailure auditing and see if you get any clues from there:

$ REPLY/ENABLE=SECURITY
$ SET AUDIT/ALARM/ENABLE=(LOGIN=ALL, LOGFAIL=ALL)

A crucible of informative mistakes
Hoff
Honored Contributor

Re: OpenVMS no inbound ftp

Apply the current ECO kits for the particular version of TCP/IP Services in use here, then restart the TCP/IP stack, as a start.

If the IP server does not resolve itself and there are any firewalls, disable them for testing. FTP is insecure; it requires the firewall to open up all traffic on the ephemeral ports on one or both ends of the connection (or deep packet inspection, which is an option on some high-end firewalls), and it ships the username and password in cleartext over the connection.

To save anyone else the hassles of accessing the propriety-format Microsoft Office Word file that was attached, it's a Word document containing an image capture representation of the TCP/IP Services FTP configuration -- with the FTP server is being enabled. (Those of us using OpenVMS or other non-Microsoft platforms and tools may or may not have the ability to read Word documents. Posting text, JPG or such is usually a better choice for attachments.)
Robert Gezelter
Honored Contributor

Re: OpenVMS no inbound ftp

Roger,

Ok. If you are running OpenVMS 7.3-2, there is a good chance that you are running TCPIP Services Version 5.4 (this can be verified by doing a TCPIP SHOW VERSION).

First question, is there a process with a name along the lines of TCPIP$FTP_1 running? If so, can you access it from the local machine? (Use the FTP client to access IP address 127.0.0.1)

Please check your console log. I have just confirmed that there is a confirmatory message of FTP startup in the console log.

- Bob Gezelter, http://www.rlgsc.com
Steven Schweda
Honored Contributor

Re: OpenVMS no inbound ftp

> See attch.

Attach plain text, not a Microsoft Word
document, and I'd consider it.

> FTP client & server are enabled & started,
> [...]

Apparently not:

> FTP 21 TCP TCPIP$FTP 0.0.0.0 Disabled

Have you tried enabling it? You might
consider SYS$MANAGER:TCPIP$CONFIG.COM as a
convenient way to do that.

Other than TCPIP SHOW VERSION, any other
actual commands you've tried, with their
actual output, could be interesting.

> 1) No error messages except when external
> machine tries to connect: connection
> rejected.

Well, yeah. The FTP service is disabled, so
the FTP server is not running.