Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS no inbound ftp

 
SOLVED
Go to solution
Don Nutt
Advisor

Re: OpenVMS no inbound ftp

Have you simply tried:

TCPIP> enable service FTP

TCPIP> show service FTP


Don
Ian Miller.
Honored Contributor

Re: OpenVMS no inbound ftp

Have you tried enabling the ftp server in TCPIP$CONFIG ?

What is in
SYS$SYSDEVICE:[TCPIP$FTP]TCPIP$FTP_RUN.LOG ?
____________________
Purely Personal Opinion

Re: OpenVMS no inbound ftp

A> TCPIP SHOW VERSION

HP TCP/IP Services for OpenVMS Alpha Version V5.4 - ECO 5
on a AlphaServer 4100 5/400 4MB running OpenVMS V7.3-2

Re: OpenVMS no inbound ftp

Some questions...

1) are you sure the requesting node has the correct address mapping? Try telnet and make sure you're reaching the right node.


Just did a "Ping" to the address of the node: All was normal. Stats: sent = 4, received = 4, lost = 0.

Re: OpenVMS no inbound ftp

First question, is there a process with a name along the lines of TCPIP$FTP_1 running? If so, can you access it from the local machine? (Use the FTP client to access IP address 127.0.0.1)

That process is NOT running. Here is what is running starting with TCPIP*


A> SHOW SYS/PROC=TCPIP*
OpenVMS V7.3-2 on node A 2-JUL-2008 08:34:00.83 Uptime 158 21:22:12
Pid Process Name State Pri I/O CPU Page flts Pages
00000216 TCPIP$INETACP HIB 10 9672 0 00:00:03.68 618 161
00000218 TCPIP$NTP_1 LEF 9 13836808 0 00:01:06.30 21264 150 N
0000021A TCPIP$SNMP_1 LEF 9 1391743 0 00:00:09.07 10149 91 N
0000021B TCPIP$HR_MIB LEF 9 470494 0 01:37:58.35 7181 92
0000021C TCPIP$OS_MIBS LEF 9 20605546 0 00:30:37.60 13286 132
00019D35 TCPIP$TNS2 HIB 6 51206 0 00:00:21.42 436 116
0000034D TCPIP$TNS1 HIB 6 10709 0 00:00:02.67 6940 21
A>

Re: OpenVMS no inbound ftp

Here's the ASCII version of the previous .doc attachment:

HP TCP/IP Services for OpenVMS Server Components Configuration Menu

Configuration options:

1 - BIND Disabled Stopped 12 - NTP Enabled Started
2 - BOOTP Disabled Stopped 13 - PC-NFS Disabled Stopped
3 - DHCP Disabled Stopped 14 - POP Disabled Stopped
4 - FINGER Disabled Stopped 15 - PORTMAPPER Disabled Stopped
5 - FTP Enabled Started 16 - RLOGIN Enabled Started
6 - IMAP Disabled Stopped 17 - RMT Disabled Stopped
7 - LBROKER Disabled Stopped 18 - SNMP Enabled Started
8 - LPR/LPD Disabled Stopped 19 - SSH Disabled Stopped
9 - METRIC Disabled Stopped 20 - TELNET Enabled Started
10 - NFS Disabled Stopped 21 - TFTP Disabled Started
11 - LOCKD/STATD Disabled Stopped 22 - XDM Disabled Stopped


A - Configure options 1 - 22
[E] - Exit menu

Enter configuration option:

Re: OpenVMS no inbound ftp

A> TCPIP SHO SERVICE FTP/FULL

Service: FTP
State: Disabled
Port: 21 Protocol: TCP Address: 0.0.0.0
User_name: not defined Process: TCPIP$FTP
A>

In addition, TCPIP$TFTP_RUN.COM hangs if try to execute.
Steven Schweda
Honored Contributor
Solution

Re: OpenVMS no inbound ftp

> [...] TCPIP$TFTP_RUN.COM hangs [...]

FTP and TFTP are different things.

Have you tried to enable/start the FTP
service yet (as repeatedly suggested)?
Wim Van den Wyngaert
Honored Contributor

Re: OpenVMS no inbound ftp

I would say it aborted.

reply/ena
ucx ena servi ftp

and check the messages and log files.

Wim
Wim
Robert Gezelter
Honored Contributor

Re: OpenVMS no inbound ftp

Roger,

As a start, please run the TCP/IP configuration procedure (SYS$MANAGER:TCPIP$CONFIG.COM) from a suitably privileged account. Then remove the FTP server and re-configure the FTP service (In TCPIP Services 5.4, the relevant options are labeled as "disable and stop" and "enable and start" respectively.

The TCPIP$FTP_1 process should then be started.

- Bob Gezelter, http://www.rlgsc.com