Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

SVNKit for OpenVMS

 
bfraga
Occasional Advisor

SVNKit for OpenVMS

Hello,

I'm trying to use the SVNKit command line in OpenVMS but I'm having some problems. I don't know very much about java, can anyone help me and tell me what can it be?

VMS version: OpenVMS V7.3-2
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition
Classic VM (build 1.4.2-4.p5, 11/22/2005-23:29, native threads, jit)

I tried to run the original version of JSVNSETUP.OPENVMS and it didn't work, I changed it but it still don't work.

The JSVN command:
JSVN == "$SYS$COMMON:[000000.JAVA$142.bin]java$java -cp svnkit_home:svnkit.ja
r;svnkit_home:svnkit-cli.jar;svnkit_home:trilead.jar;svnkit_home:jna.jar;svnkit_
home:sqljet_1_0_0_b616.jar;svnkit_home:antlr-runtime-3_1_3.jar "org.tmatesoft.sv
n.cli.svn.SVN""

svnkit_home is defined:
"SVNKIT_HOME" = "$1$DGA19:[SVN]" (LNM$JOB_81252F00)

When I tried to run the jsvn I got the following error:
Exception in thread "main" java.lang.NoClassDefFoundError: org/tmatesoft/svn/cli
/svn/SVN

It can't find the SVN class.
6 REPLIES 6
H.Becker
Honored Contributor

Re: SVNKit for OpenVMS

Are all the .jar files in Stream_LF format?
bfraga
Occasional Advisor

Re: SVNKit for OpenVMS

I've converted all the files to this format, and it still don't work:

SVNKIT-CLI.JAR;2 File ID: (192383,20,0)
Size: 622/644 Owner: [SYSTEM]
Created: 30-OCT-2009 10:23:45.82
Revised: 30-OCT-2009 10:23:45.83 (1)
Expires:
Backup:
Effective:
Recording:
Accessed:
Attributes:
Modified:
Linkcount: 1
File organization: Sequential
Shelved state: Online
Caching attribute: Writethrough
File attributes: Allocation: 644, Extend: 0, Global buffer count: 0
No version limit, Contiguous best try
Record format: Stream_LF, maximum 0 bytes, longest 512 bytes
Record attributes: Carriage return carriage control
RMS attributes: None
Journaling enabled: None
File protection: System:RWED, Owner:RWED, Group:RWED, World:R
Access Cntrl List: None
Client attributes: None

I've changed some .jar file names to work in VMS, for example, I changed the file "antlr-runtime-3.1.3.jar" to "antlr-runtime-3_1_3.jar".
H.Becker
Honored Contributor

Re: SVNKit for OpenVMS

If the jars are not in the correct format, do not convert, just do $ set file/attr=rfm=stmlf.
Jansen_8
Regular Advisor

Re: SVNKit for OpenVMS

I do not think the file-settings are wrong. On my Alpha with OpenVMS8.3 and Java 1.5.0-5 it works "out of the box"
I just unzip the files with a "recent" unzip.exe.

My suspicion is the version of Java. I'm not sure java 1.4.x will work for svnkit. I could not find anything on the java-version on the svnkit webpage, but maybe you could ask, which is the minimal java version to the svnkit mailing list (see their web-site).

Jouk
Richard Brodie_1
Honored Contributor

Re: SVNKit for OpenVMS

Looks like the classpath is mangled unless there is some option I don't know about.

Try changing all the colons in the classpath to slashes and the semicolons to colons.
bfraga
Occasional Advisor

Re: SVNKit for OpenVMS

The classpath was really wrong. I changed it and it worked.
Thanks for your help.