Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Tilde and CSWB

Jack Trachtman
Super Advisor

Tilde and CSWB

I have a PC keyboard connected to my Alphaserver (I know, I know). In the New Desktop, under Options/Keyboard I set

Angle Brackets Key Sends `~
Comma Key Sends ,<

and my DECterm shows what I type for these symbols.

In CSWB, sometimes I can get the ` and ~ to appear when I type them, other times I get
< or >.

How to I get CSWB (latest vesion) to display ` and (especially) ~? TIA
2 REPLIES
Wim Van den Wyngaert
Honored Contributor

Re: Tilde and CSWB

May be related ?

The key bindings for the six keys in the middle of the keyboard (which include PAGE UP or REMOVE) assume that you have an LK style keyboard. If you have a PC style keyboard, you should define the logical GTK_KEY_MAPPING_MODE to 2 before running Mozilla. For example:

$ DEFINE GTK_KEY_MAPPING_MODE 2
Valid values for GTK_KEY_MAPPING_MODE are:
0 - no mapping
1 - LK keyboard (default)
2 - PC keyboard

Wim
Wim
Jack Trachtman
Super Advisor

Re: Tilde and CSWB

I have GTK_KEY_MAPPING_MODE 2 already set.

What's odd is that the Keyboard setting in my DECterm window has "Tilde Key Sends ~", which works correctly. But I just happened to notice that my Escape key works like the ~ key (ie, unshifted Esc sends ` and shifted Esc sends ~)!

Any more suggestions?