Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

set terminal speed won't

 
SOLVED
Go to solution
bkelly13
Advisor

set terminal speed won't

I need to the speed of a LAT port. We have a .COM file to set printer lat ports that contains, in part:

set terminal /perm.../set speed/speed=(19200, 19200) .../hangup

The previous speed was 1200 and after running this COM file, it is still 1200. I verified this with a protocol analyzer and by setting the printer to 1200. It works, but painfully slow.

The VAX Fault Tolerant 810 is running Open VMS version 5.2 and connected to a XYPLEX terminal server that contains the port. Is this a setup that works only once then I must kill it and start over again?

What do I need to do to get the VAX / XYPLEX to listen to my speed change.
Thank you.
6 REPLIES 6
marsh_1
Honored Contributor
Solution

Re: set terminal speed won't

hi,

i would sugges you investigate the speed of the port on the terminal server, then retry your command on the vax, a user manual is here :-

http://www.pimpworks.org/xyplex/xyplex.html

hth

Jess Goodman
Esteemed Contributor

Re: set terminal speed won't

In order for a SET TERMINAL command on the VAX to have any effect on the Xyplex's terminal server port that it is connected to you must first set the Xyplex port to enable remote modifications.

Xyplex>> DEFINE PORT n REMOTE MODIFICATION ENABLED
Xyplex>> SET PORT n REMOTE MODIFICATION ENABLED

If you have older Xyplex software/hardware that does not support this command then the terminal speed can only be changed at the Xyplex port:

Xyplex>> DEFINE PORT n SPEED 19200
Xyplex>> SET PORT n SPEED 19200
I have one, but it's personal.
John Gillings
Honored Contributor

Re: set terminal speed won't

bkelly13,

Just to put this in context... the speed between the terminal server and the printer has nothing to do with the "speed" of the LTA device on the OpenVMS system. OpenVMS is talking to the terminal server at network speed, so SET TERM/SPEED is pretty much meaningless.

It's possible there is no direct way to change the serial port speed from OpenVMS, it needs to be done from the terminal server.

Once you've worked out that part, please remember that faster is not always better.

Be very careful about increasing the serial line speed to a printer. If the printer is of the same vintage as the rest of your systems, I'd be very surprised if it could take 19200 baud. Chances are it uses XON/XOFF flow control, which doesn't work properly above 4800 baud - purely because of line speed latencies. Work out the maximum speed that the printer can physically put characters on paper, and don't set the line speed above it.

Most printers around when V5.2 was current could manage 2400 baud, but not much higher. The problem was mostly seen when using terminal servers, as the OS was feeding characters at 10Mbit over the network, which were being buffered on the terminal server. When the printer said XON, it got a flood of characters at 19200 into its tiny buffer, and by the time it realised and sent an XOFF, the buffer had already overflowed and characters were lost. Upshot was, running at a higher speed was really just exercising the flow control mechanism at rates well above its design limits. Since the dumb serial protocol had no resend capability and stuff broke!

I solved many printer problems by reducing the line speed.

A more modern printer may be able to take a higher speed, but even so, I'd strongly recommend a more cautious approach to increasing speed. Get a file that prints over several pages - at least 5. Send it at 1200 and time how long it takes at the printer. Repeat at 2400, then 4800, then 9600. At some point the printer itself will be the bottle neck, and increasing the baud rate won't increase the speed the paper comes out. Choose the LOWEST baud rate which results in the highest print speed.
A crucible of informative mistakes
bkelly13
Advisor

Re: set terminal speed won't

Thanks for the responses. We have the Xyplex manuals so I will go there and set up the ports on it. I was thinking that the speed would be passed through but obvioulsy that was incorrect. The printer is a late model laser printer and was set to 19200 on another VAX and we moved it. Just the same, (I cannot see the replys right now), I think Gillings has the right concept, the lowest speed that provides acceptable results.

Thanks and I will try this in the next couple of days and bet back with the results.
bkelly13
Advisor

Re: set terminal speed won't

I have been able to connect to the Xyplex and set and define the characteristics. 9600 is fast enough and the printer is working.
Thank you for your help,
Bryan
bkelly13
Advisor

Re: set terminal speed won't

Oops, should have done this rather than using reply.