Operating System - OpenVMS
Showing results for 
Search instead for 
Did you mean: 

Re: ssh drops characters occasionally

Frequent Advisor

ssh drops characters occasionally

Is there a different type-ahead setting available for SSH?

When we were forced to switch from Telnet to SSH we see the occasional dropped character. Sometimes it's during typing and others when displaying a form.

I tried opening a case with HP but since it's so intermittent they weren't much help. It seems related to the server side since it happens with the VMS SSH client or Reflections client. Both versions 5.6 and 5.7 on Integrity.
Honored Contributor

Re: ssh drops characters occasionally

VMS sshd has been in use for a whole long time with this stuff and - while not bug free - a whole lot of people have pounded on the ssh server. Which points to something else contributing to the "fun" here.

I'd start with the keyboard, I'd then look problems with the proximate (client) host box (probably running Windows XP?), then to the network connection from the XP box to the host, and then at the patch revision with the OpenVMS server.

Have all your tests involved a specific Windows XP box or a specific Windows configuration? You've obviously attempted to narrow one end of the configuration, but have you (also) looked at issues with, for instance, the (particular) Reflections client?

If you are using the same Reflections client (on Windows XP boxes?), is it current? Tried a different client box?

Re: ssh drops characters occasionally

I always use Putty to do SSH-sessions to OpenVMS 7.3-2 and 8.3 Alpha. I paste a lot of text and never had a dropped character (afaik). So try Putty for a few days.
Honored Contributor

Re: ssh drops characters occasionally


Dumb question. Assuming your client is a PC, what kind of keyboard are you using?

One PC I use fairly regularly has a wireless keyboard which drops characters if you type too fast. If the one you're having trouble with is wireless, try a wired keyboard (or replace the batteries).
A crucible of informative mistakes
Frequent Advisor

Re: ssh drops characters occasionally

This happens on multiple PC's. Laptops and desktops. So I'm pretty sure it isn't a keyboard issue.

It could be a Reflection's issue since even when we are using VMS ssh client we are using Reflection to access that first VMS machine.

It does go across multiple versions of Reflections. We are in a middle of a PC refresh cycle so some PC's are new with Windows 7 and others are older with Windows XP.

It is also across multiple servers - Alpha's and Itanium's. Most aren't terribly busy although we will have some sites with small network pipes to the WAN and they can get slow.

It doesn't happen enough where I get a lot of complaints. Since SSH involves two processes per session that's why I was looking for another type-ahead buffer setting.
Honored Contributor

Re: ssh drops characters occasionally

You're probably not going to really get anywhere here, either.

The odd part here is that this isn't cropping up elsewhere.

This could be Windows, batches of bad keyboards, the network, Reflections, VMS, and pretty much anything.

Look for key-loggers, security tools, and any gateway that seeks to MITM the ssh connections, too.

Definitely look at newer versions of Reflections.

I'd probably start testing with a MacBook, and see if I could replicate the problem. Carve off a hunk of the problem, and see what you get.