Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

Re: Boot Problem


Boot Problem

Tru64 v 5.1B

Changed kernel parameter for oracle10g R2 and rebooted the system.

Got numerous errors : like Sysconfig tab attributes not set in subsystem ipc...and more..

I am able to login to single user mode now.
Replaced the original sysconfigtab file.
Still I got the same problem.

I tried bcheckrc and
got the following error:

Checking device naming:
Checking local filesystems
Mounting / (root)
Cannot find boot filesystem mount point
mountroot: Please correct the mount problem and reboot

I tried running bcheckrc and got the same error message. The following is my /etc/fstab file:

root_domain#root / advfs rw 0 0
/proc /proc procfs rw 0 0
usr_domain#usr /usr advfs rw 0 0

The root domain is currently mounted and I could successfully mount the usr domain as well.

Any ideas on how I can fix this?

Please let me know if i need to try anything else,its very urgent for me to get this system up.Thank you.

Re: Boot Problem

In addition to that I am getting the following error:
INIT: Command is respawning too rapidly. Check for possible errors.
id: esmd "/usr/sbin/esmd /dev/null 2>&1"

INIT: Command is respawning too rapidly. Check for possible errors.
id: cons "/usr/sbin/getty console console vt100"

Re: Boot Problem

Have anyone tried to rebuild a new kernel ?
In single user mode, sysconfig -s - shows nothing. sysconfigtab and sysconfigdb -l are perfect, but while booting both both vmunix and genvmunix are not able to get these attribute values.
Honored Contributor

Re: Boot Problem


Go back to the beginning...

Exactly what did you change when you "changed kernel parameter" ?

The errors "...attributes not set in subsystem..." should not stop the system booting. They're just an indication of typos in /etc/sysconfigtab.

What's the hardware configuration ? Clustered ?



Re: Boot Problem

Hi thanks for your response.
The system is not clustered.I have replaced it with the original sysconfigtab.All I have is usuable single user mode.
I believe syconfig with wrong parameters changed the setting of running kernel.I dont have a log to tell you the exact parameters,sorry.
When the system boots it checks ./vmunix or /gemvmunix as per the selection and both kernel are not allowing me to login.
/vmunix or /gemvmunix are not updating the current information from sysconfigtab.
Do you think is it possible for me to replace these two files from tape or to build a new kernel ?
Honored Contributor

Re: Boot Problem


I'm not entirely sure what's gone wrong, but you might want to try booting from the generic kernel, and rebuilding a new one.

P00>>> b -fl s -fi genvmunix

Once at single user,

# mountroot
# mount /usr
# mount /var
# doconfig

Once the kernel has been built, you will need to copy it to /

Hope this helps,



Re: Boot Problem

Just done a rebuild, same issue.It looks like problem is not with the kernel.
Mounting / ( root )
Cannot find boot filesystem mount point.
mountroot:please correct the mount problem and reboot.I am not sure how to fix this issue.


#dn_setup â sanity_check - passed
#dn_setup â init
#dsfmgr â K
#dsfmgr â v is successful
#disklabel â r dsk0 and dsk1 are fine.
#/etc/fstab and inittab looks fine.


Re: Boot Problem

From the single user mode I found the important consvar attributes are not set.
I tried
consvar -g booted_dev
booted_dev =
consvar -s boot_dev dsk0
consvar -a
No idea these changes are not effective after a boot.

Honored Contributor

Re: Boot Problem

Hi Alagappan,

Not sure if this could be a cause ?
Have you checked /etc/fdmns ? Are the links pointing correctly to the proper device names ?


Re: Boot Problem

Hi Nindad

I have tried that.Its same.Thanks