Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

CPIO problem

Go to solution
Frequent Advisor

CPIO problem

hi all,
I have been using CPIO for a while, but yesterday, we started experiencing a strange phenomenom. When the command was executed, the root filesystem just kept increasing, and then when it was full, the backup requested another volume. The syntax of the backup command I used is

find bnk -print | cpio -ovcC51200 -O /dev/ntape/tape0

Am I doing something wrong? Any assistance will be appreciated
Cortes Albertino
Trusted Contributor

Re: CPIO problem


You must check first if the special file is already a char device.

try it :
#ls -l /dev/ntape/tape?
crw-rw-rw- ...............

#/bin/file /dev/ntape/tape?
should be as follows, i.e. character special
/dev/ntape/tape0: character special (19/222)
/dev/ntape/tape5: character special (19/280) SCSI #0 "TLZ6" tape #4 (SCSI ID #0) (SCSI LUN #4) offline

Hope it helps,

Albertino Cortes
Frequent Advisor

Re: CPIO problem

hello Albertino cortes,
it turns out that the character file for the device had been deleted (mistakenly?), and so whenever the customer tried to run the backup, the command simply created a file, and started to copy the files there. naturally, the file soon filled the root partition. I re-created the device file (mknod with -c) and the script worked wonderfully.