Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

DP - Oracle Integration setup problem

Juan Canjura
Advisor

DP - Oracle Integration setup problem

Hi all,

I've been trying to setup the "Oracle Integration" on DP and I think I've followed all the steps described in the documentation but still I'm getting the same problem.

I'm stuck trying to configure an Oracle (8.1.7.4) instance running on Unix. When I define the "Client, Application Database, Username, Group name" in the GUI everything seems to be ok.. then, I jump into the "Configure Oracle" screen, enter all the information on the General and Connection tabs and when I click on "Next" I got NO errors in the RMAN messages:

RMAN-06005: connected to target database: XXX (DBID=123)

RMAN-06008: connected to recovery catalog database

After that screen I got the 12:8324 error "This Oracle Server instance is not configured", indeed is not configured because the configuration files ARE NOT created on the Cell Manager unless I run the "/usr/omni/bin/util_oracle8.exe -CONFIG ..." from the server that's running the instance as "oracle" user.

While I try to configure the instance from the GUI, the oracle8.log is stating:

(Wed Apr 25 15:40:07 CST 2007) Starting /usr/omni/bin/util_oracle8.exe -CHKCONF ...
Error in util_oracle8.exe @ fix_env:17 !!!
Cannot acquire Oracle's HOME directory.
Check the configuration.

I've tried to run the GUI from an XWindows logged on as "oracle" with exactly the same problem.

Any light on this will be greatly appreciated.
Thanks in advance.

Juan
3 REPLIES
Juan Canjura
Advisor

Re: DP - Oracle Integration setup problem

Any idea?
Hein van den Heuvel
Honored Contributor

Re: DP - Oracle Integration setup problem

I have no experience with this particual area, but the error message strongly suggests that there is something wrong with the environment variables.

Can you properly connect using plain SQLplus?

Is there a specific accoutn set up for rman?

#su - 'rman-account'
#env | grep ORA

There should be an ORACLE_HOME and ORACLE_SID and also NLS..

If this was my problem, then I'd first go call Oracle support and/or check an Oracle specific forum (where they will start questioning why 8.i is still being used :-).

In desperation I would then try to debug it my self using 'trace -f', maybe -o
This will spit out lots and lots of data.
The first screenfulls are probably all fluff activating libraries.
The last screenfulls are probably all about printing the error messages.
But 50 - 150 lines before the end you are likely to see Oracle to basic file lookups and opens and eventually see a failign operation, which with a bit of luck you can interpret to explain the problem.

Good luck!
Hein.
Rob Leadbeater
Honored Contributor

Re: DP - Oracle Integration setup problem

Hi Juan,

If you're still stuck, ask Tim over at http://www.oracle-base.com/forums

Cheers,

Rob