Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

Landscape printing using an HP4050 laserjet


Landscape printing using an HP4050 laserjet

I have a customer who is stuck trying to print to an HP4050 in landscape mode with 132 cols. Regardless of what she tries, it always comes out portrait 80 cols. Here is her printcap entry:

:if=/usr/lbin/ppdof +OPageSize=Landscape +Chplj4050.rpd:\
:of=/usr/lbin/ppdof +OPageSize=Landscape +Chplj4050.rpd:\

She knows that the printer will do it because it is also used by a VAX and it works fine. What is the secret?
Abdul Rahiman
Esteemed Contributor

Re: Landscape printing using an HP4050 laserjet

What command is she using to print?
Has she tried using the "-O lansdcape" option with lpr from the command line to see if that's printing OK on landscape mode.
lpr -h -O landscape file
No unix, no fun
Ralf Puchner
Honored Contributor

Re: Landscape printing using an HP4050 laserjet

If using rm: and rp: (lpd printing) will not honor the printfilter. Change the setup to tcp printing and it will work.

Your printcap entry looks strange to me (parallel and network printing specified, ppdof "postscript" filter used but printing to text port). Please use the supported tool lprsetup or the sysman station for setup to prevent such misconfiguration!

Simple test: pipe the printfile into the printerfilter and print the output file.

The 4050 is a PCL and PS printer, so use the correct filter depending on the input file!

If you are not sure about the basics, please have a look into the man-pages (printcap) and admin guide!
Help() { FirstReadManual(urgently); Go_to_it;; }