Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

Unaligned access pid

Unaligned access pid

Hi All
I am getting Unaligned access pid=438691 error in my /tmp directory, this error is created as special files and i am not able to delete this files. I dont know what is this error and why any process creating there.

I tried to check the process by fuser /tmp and till the time i check the process it goes from the process table.

How can I check which process is creating this special file and how can i get rid of this.

some time fuser /tmp dont show me any process running on this file system but Unalligned access pid continuesly changing its PID ??

Ralf Puchner
Honored Contributor

Re: Unaligned access pid

Messages like

Unaligned access pid=6103 va=0x1400eb033 pc=0x12030b2208


Unaligned access messages are informational in nature, and occur due to a data item which is not on its natural boundary. The operating system, by default, will fix the problem and give the unaligned access messages. Typically, such errors are not a problem, and can be ignored. Sometimes, an excess number of messages signals a poorly written program with potential performance problems.

You can disable this message by using the uac command.
Help() { FirstReadManual(urgently); Go_to_it;; }

Re: Unaligned access pid

thanks for reply but i am getting this error only in my /tmp directory. when i disable the mesg. via uac i see "? # 5? i? manabceaa sh390642gaQy0" a special file which i can not delete and when i enable the "uac" my "ls" command retrun this error ... ?
Unaligned access pid=37255 va=0x140074e1d pc=0x120022650 ra=0x120014170 inst=0xa0e00004

i.e my ls command giving this error or it is a some OS bug !!

any idea what is this !!
Ralf Puchner
Honored Contributor

Re: Unaligned access pid

it seems to be an application or hardware specific problem. Btw. have you checked binary.errlog for hardware issues (maybe a cpu problem)?

what happend if you are in single user mode? does the problem also occure?

Help() { FirstReadManual(urgently); Go_to_it;; }
Johan Brusche
Honored Contributor

Re: Unaligned access pid

Normally the "Unaligned access" messages, caused by the badly coded APPLICATION, appear on the terminal that launched the application.
I suspect that the application has no tty attached anymore and redirects stderr to /tmp.

For what reason do you call this file in /tmp "special", because it has a p, b or c in the first column of the 'ls -l'output , or because it has a name with strange characters ?
If rm does not work because of the special characters, you probably wil have to use "rm *" in /tmp (or in single user mode, "rm -r /tmp" and recreate /tmp/



Re: Unaligned access pid

Ralf and Jphan
You both looking the problem in a right way it seems to me...

Ralf, i already opend a call in HP for this problem but they are taking some time because of some admin. problem, but few days back my machine crashed stating "panic (cpu 12): vm_pg_alloc: page not free" but local HP is doubting on one patch "001163" which corret this problem but they did not indicated any hardware problem.

John, as I said in my previous mail that if i used fuser /tmp i dont see any process on /tmp and that is why I m not able to understand which program is using this file, and how this file is created in /tmp, and more funny thing when i sey "ls" under the /tmp directory it repeats the "Unassgined error for the ls command"

sorry for writing confusing word actaully i mean a strange file created in /tmp as i mentioned above, i tried to delete this file as you said but nothing work, i think i have to delete this in single user mode.

PS: John as you said there is no tty assigned to this prog. that is why it is redirecting to /tmp, if this is the case then why i am seeing "Unassgined" when using ls command