Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

disabling ctrl-e key

shyam_6
Occasional Contributor

disabling ctrl-e key

Hi all

I want to disable ctrl-e key so that it wont respond for user if he presses ctrl-e.i am not getting signal number for ctrl-e key.With signal number i hope i can use the command
trap '' in user profile.
OS : tru64unix 4.0f
user shell is KSH.Is there any other way to acheive this.


Thanks
1 REPLY
Dave Bechtold
Respected Contributor

Re: disabling ctrl-e key

Hello,

Are the users entering the e while at a ksh prompt or from within a program. like vi ?

If the user is at a shell prompt then take a look at the terminal characteristics using "stty -a" and see if they have set a special character using e = ^E for something like eol. These can be set using stty command, check the man page. Also, if the user is setup for emacs/gmacs editing mode in ksh the e will move the cursor to the end of the current line - this is a builtin feature with use emacs editing mode within ksh. I'm not sure if that is configurable.

If it's within a program then I believe the program/application would be setting this up.

By default using TERM type of vt100 or vt320 within ksh, e does nothing more than echo the character sequence back - ^E.

Hope this helps,
Dave Bechtold