Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

How to Create Trunk Between Cisco Catalyst-3560-CX Series Switch & HP Procurve 2510-48 Switch

vdj3000
Occasional Contributor

How to Create Trunk Between Cisco Catalyst-3560-CX Series Switch & HP Procurve 2510-48 Switch

Hello Everyone,

 I want to configure trunk between Cisco Catalyst-3560-CX Series Switch (Layer 3 Switch) which has 12 Gigabit ethernet ports & HP Procurve 2510-48 Switch (Layer 2 Switch) which has 48 Fast ethernet ports. Both are manageable switch. However cisco is Gigabit ethernet and HP is Fast ethernet. I have 6 VLANs on cisco switch. I want to create trunk between Cisco and HP switch. I dont want to create VLANs on HP switch. I just want to trunk between them without creating VLANs on HP switch. How to verify if trunk is working fine after configuration.

5 REPLIES
parnassus
Honored Contributor

Re: How to Create Trunk Between Cisco Catalyst-3560-CX Series Switch & HP Procurve 2510-48 Switc


vdj3000 wrote:

Hello Everyone,

 I want to configure trunk between Cisco Catalyst-3560-CX Series Switch (Layer 3 Switch) which has 12 Gigabit ethernet ports & HP Procurve 2510-48 Switch (Layer 2 Switch) which has 48 Fast ethernet ports. Both are manageable switch. However cisco is Gigabit ethernet and HP is Fast ethernet.

Well, that's not an issue because the very important thing is to set/configure on both ends of the trunk (Cisco<-->HP) the same speed/duplex settings...this mean that your trunk speed will be governed by (and somewhat limited by) the slowest port's speed you have on one of the uplink ends: the Fast Ethernet one (HP side).


vdj3000 wrote: I have 6 VLANs on cisco switch. I want to create trunk between Cisco and HP switch. I dont want to create VLANs on HP switch. I just want to trunk between them without creating VLANs on HP switch. How to verify if trunk is working fine after configuration.
A little bit strange: if no (tagged) VLAN traffic will be permitted to flow on that trunk connection and if no (corresponding) VLAN(s) are also defined on the HP Switch...what will be the ultimate purpose of that inter-Switch trunking connection? which traffic do you think will that trunk be able/permitted to transport between the Cisco and the HP (apart the traffic that belongs to Default VLAN Id of - or shared by - both ends, if not already mismatched at Default VLAN Id level)?
 
Hope to have understood correctly what you're trying to achieve...
vdj3000
Occasional Contributor

Re: How to Create Trunk Between Cisco Catalyst-3560-CX Series Switch & HP Procurve 2510-48 Switc

I made the following configurations on Cisco Switch and HP Switch

CISCO SWITCH

Switch-1>en
Switch-1#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-1(config)#int g0/14
Switch-1(config-if)#switchport trunk native vlan 1
Switch-1(config-if)#switchport mode trunk
Switch-1(config-if)#switchport nonegotiate
Switch-1(config-if)#no shut
Switch-1(config)# no cdp enable

However this command "Switch-1(config-if)#switchport trunk encapsulation dot1q" is not working/invalid on this switch. As when i see trunk info by using "sh int trunk" i get below details. So encapsulation dot1q is enabled by default when you enable trunk.

Switch-1#sh int trunk

Port              Mode       Encapsulation      Status      Native vlan
Gi0/14            on              802.1q                trunking        1

Port              Vlans allowed on trunk
Gi0/14           1-4094

Port               Vlans allowed and active in management domain
Gi0/14           1,100-105

Port              Vlans in spanning tree forwarding state and not pruned
Gi0/14           1,100-105

HP SWITCH

ProCurve Switch 2510-48# config t
ProCurve Switch 2510-48(config)# int 14
ProCurve Switch 2510-48(eth-14)# enable
ProCurve Switch 2510-48(eth-14)# trunk 14 trk1
ProCurve Switch 2510-48(eth-14)# exit
ProCurve Switch 2510-48(config)# vlan 100
ProCurve Switch 2510-48(vlan-100)# tagged trk1
ProCurve Switch 2510-48(vlan-100)# exit
ProCurve Switch 2510-48(config)# vlan 101
ProCurve Switch 2510-48(vlan-101)# tagged trk1
ProCurve Switch 2510-48(vlan-101)# exit
ProCurve Switch 2510-48(config)# vlan 102
ProCurve Switch 2510-48(vlan-102)# tagged trk1
ProCurve Switch 2510-48(vlan-102)# exit
ProCurve Switch 2510-48(config)# vlan 103
ProCurve Switch 2510-48(vlan-103)# tagged trk1
ProCurve Switch 2510-48(vlan-103)# exit
ProCurve Switch 2510-48(config)# vlan 104
ProCurve Switch 2510-48(vlan-104)# tagged trk1
ProCurve Switch 2510-48(vlan-104)# exit
ProCurve Switch 2510-48(config)# vlan 105
ProCurve Switch 2510-48(vlan-105)# tagged trk1
ProCurve Switch 2510-48(vlan-105)# exit
ProCurve Switch 2510-48(config)# no cdp enable all


When i see trunk info, i get the following

ProCurve Switch 2510-48# sh trunk

Load Balancing

Port |    Name                     Type    |   Group         Type
---- + -------------------------------- --------- + ----- -----
14 |                                  10/100TX |    Trk1           Trunk

When i see VLAN info, i get the following info

ProCurve Switch 2510-48# sh vlan

Status and Counters - VLAN Information

Maximum VLANs to support : 8
Primary VLAN : DEFAULT_VLAN
Management VLAN :

VLAN ID                 Name        Status   Voice
------- --------------------         ------------ -----
1              DEFAULT_VLAN     Port-based No
100                     VLAN100     Port-based No
101                      VLAN101      Port-based No
102                     VLAN102      Port-based No
103                     VLAN103      Port-based No
104                     VLAN104     Port-based No
105                     VLAN105      Port-based No

After doing this configuration on both the switches, i am unable to establish the connection between cisco & HP switch.

Please Help me out

luckyh
Advisor

Re: How to Create Trunk Between Cisco Catalyst-3560-CX Series Switch & HP Procurve 2510-48 Switc

And again it is the misunderstanding / different use of the terminiology "trunk"

In the cisco world the term trunk is used for either dot1Q or ISL protocol to transfer multiple vlans over one physical link (ISL is cisco propiatary and deprecheated that why the command is rejected on newer firmware) Link aggregation (in cisco world port-Channel / channel-group is used to create a bundle of links to the same destination)

In the HP world the term trunk is used only for link aggregation either static or via LACP (802.3ad) Refering to your config snipplets on the HP side you create a trunk with only one interface which does not make sense et all.

I would delete the trk statement and assign the vlans untagged and tagged direct on the interface 14 on the HP side

 

vdj3000
Occasional Contributor

Re: How to Create Trunk Between Cisco Catalyst-3560-CX Series Switch & HP Procurve 2510-48 Switc

Request you to, please share the configuration so that i will try on Cisco & HP switch.  Waiting for your reply

vdj3000
Occasional Contributor

Re: How to Create Trunk Between Cisco Catalyst-3560-CX Series Switch & HP Procurve 2510-48 Switc

I made the following changes to the configuration and obtained this outputs -

Switch-1(config)#int g0/14
Switch-1(config-if)#switchport trunk native vlan 1
Switch-1(config-if)#switchport mode trunk
Switch-1(config-if)#switchport nonegotiate
Switch-1(config-if)#speed auto
Switch-1(config-if)#duplex full
Switch-1(config-if)#flowcontrol receive on
Switch-1(config-if)#no cdp enable
Switch-1(config-if)#channel-group 1 mode on
Switch-1(config-if)#channel-group 1 mode active
Switch-1(config-if)#exit
---------------------------------------------------------------------------------------------------------------

Switch-1#sh vlan brief

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/1, Gi0/2, Gi0/3, Gi0/4
Gi0/11, Gi0/12, Gi0/13, Gi0/14
Gi0/15, Gi0/16
100 Senior Mgmt active Gi0/5
101 ConferenceRoom active Gi0/6
102 MICM Users Admin active Gi0/7
103 Classrooms active Gi0/8
104 ETTI College active Gi0/9
105 ComputerLab active Gi0/10
1002 fddi-default act/unsup
1003 trcrf-default act/unsup
1004 fddinet-default act/unsup
1005 trbrf-default act/unsup

---------------------------------------------------------------------------------------------------------------
Switch-1#show log

Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.



No Inactive Message Discriminator.


Console logging: level debugging, 60 messages logged, xml disabled,
filtering disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level debugging, 60 messages logged, xml disabled,
filtering disabled
Exception Logging: size (4096 bytes)
Count and timestamp logging messages: disabled
File logging: disabled
Persistent logging: disabled

No active filter modules.

Trap logging: level informational, 62 message lines logged
Logging Source-Interface: VRF Name:

Log Buffer (4096 bytes):
17 10:46:49.681: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/14, changed state to up
Feb 17 10:47:18.685: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Feb 17 10:47:18.685: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
Feb 17 10:47:18.688: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan101, changed state to up
Feb 17 10:47:18.709: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan102, changed state to up
Feb 17 10:47:18.709: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan103, changed state to up
Feb 17 10:47:18.709: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan104, changed state to up
Feb 17 10:47:18.713: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan105, changed state to up
Feb 17 10:48:15.364: %SYS-5-CONFIG_I: Configured from console by console
Feb 17 10:50:26.387: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
Feb 17 10:50:26.390: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down
Feb 17 10:50:26.390: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan101, changed state to down
Feb 17 10:50:26.390: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan102, changed state to down
Feb 17 10:50:26.394: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan103, changed state to down
Feb 17 10:50:26.394: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan104, changed state to down
Feb 17 10:50:26.394: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan105, changed state to down
Feb 17 10:50:27.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/14, changed state to down
Feb 17 10:50:29.389: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/14, changed state to up
Feb 17 10:50:58.033: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Feb 17 10:50:58.036: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
Feb 17 10:50:58.036: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan101, changed state to up
Feb 17 10:50:58.036: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan102, changed state to up
Feb 17 10:50:58.040: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan103, changed state to up
Feb 17 10:50:58.040: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan104, changed state to up
Feb 17 10:50:58.043: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan105, changed state to up
Feb 17 10:51:39.095: %SYS-5-CONFIG_I: Configured from console by console
Feb 17 10:52:43.876: %EC-5-CANNOT_BUNDLE2: Gi0/14 is not compatible with Po1 and will be suspended (flow control receive of Gi0/14 is on, Po1 is off)
Feb 17 10:52:43.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
Feb 17 10:52:43.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down
Feb 17 10:52:43.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan101, changed state to down
Feb 17 10:52:43.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan102, changed state to down
Feb 17 10:52:43.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan103, changed state to down
Feb 17 10:52:43.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan104, changed state to down
Feb 17 10:52:43.894: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan105, changed state to down
Feb 17 10:52:44.869: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/14, changed state to down
Feb 17 10:53:33.292: %EC-5-CANNOT_BUNDLE2: Gi0/14 is not compatible with Po1 and will be suspended (flow control receive of Gi0/14 is on, Po1 is off)
Feb 17 10:54:07.717: %EC-5-CANNOT_BUNDLE2: Gi0/14 is not compatible with Po1 and will be suspended (flow control receive of Gi0/14 is on, Po1 is off)
Feb 17 10:54:09.391: %EC-5-CANNOT_BUNDLE2: Gi0/14 is not compatible with Po1 and will be suspended (flow control receive of Gi0/14 is on, Po1 is off)
Feb 17 10:54:37.517: %SYS-5-CONFIG_I: Configured from console by console
Feb 17 10:56:39.281: %SYS-5-CONFIG_I: Configured from console by console
Switch-1#