ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Controller is locked by another instance of ACU.

JeroenW_
Occasional Visitor

Controller is locked by another instance of ACU.

I've got a collection of blade servers that recieve cluster storage from a pair of MSA1000s.
One of the disks has a red warning light but still shows some activity. When I try to look ath the msa1000 with the GUI tool it starts and quits immediately. The CLI tool does start up but gives me:

Error: MSA1000 at SGM052812K is locked by another instance of ACU.

Now, I've look at the running processes of all the connected nodes but can't find any array configuration utilities running.

Is there a trick to kick that ghost session that prevents me from running the acu?
2 REPLIES
Oskar Enoksson
Occasional Visitor

Re: Controller is locked by another instance of ACU.

I have a similar problem. When I run hpacucli I get:

hpacucli --help

Error: Another instance of ACU is already running (possibly a service). Please terminate the ACU application before running the ACU CLI. Press ENTER to exit.

There is no other session/service running, although I ran a firefox session recently which crashed. Now I can neither use the web interface nor hpacucli. I have killed all cpqacuexe processes by hand but it doesn't help.

How can I correct the problem without rebooting?

My installed rpms are
hpsmh-2.1.12-200
hpacucli-8.10-2
hp-health-8.1.1-14.rhel5
hpadu-8.10-4

The system is centos 5.1 (redhat el5)
okroeger
Occasional Visitor

Re: Controller is locked by another instance of ACU.

hpacucli sometimes is complicated, to say the least. To get it running again, follow the following steps:

 

 

(1) Make sure that there is no other instance:

 

# ps -e | grep hpacucli

 

If hpacucli is still running, this will print something like this:

 

  762 pts/15   00:00:00 hpacucli
  775 pts/15   00:00:02 .hpacucli

First, kill the process named "hpacucli" (without the leading "."); then check if ".hpacucli" (with the leading ".") is still running; if this is is the case, kill it too.

 

 

(2) hpacucli is a shell wrapper for .hpacucli and creates the following lockfiles:

  • ACU-XE
  • CLI_SCRIPTING_MUTEX
  • CPQACU_MUTEX

Depending on your version of hpacucli, these files reside in one of these two locations:

  • /var/opt/compaq/locks
  • /opt/compaq/cpqacuxe/bld/locks

Remove those files, but be careful, they are not specific to hpacucli, but used by other HP tools as well.

 

 

(3) If this fails as well (as it did for me), try to remove all traces of hpacucli from your system and reinstall, in Debian you can do this by:

 

# dpkg --purge hpacucli

# aptitude install hpacucli

 

For the second line to work, you need to add the following line to /etc/apt/sources.list:

deb http://downloads.linux.hp.com/SDR/downloads/ProLiantSupportPack/ lenny/current non-free

 

That did the trick for me, good luck.