ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL140 interrupts problem

Andrej Solovyev
Occasional Visitor

DL140 interrupts problem

The specs are:
Dual Xeon 2.8 Ghz, 2GB

System:
Kernel Version 2.6.9-34.ELsmp (SMP)
Distro Name CentOS release 4.3 (Final)

Here is what sysinfo shows:
Processors 4
Model Intel(R) Xeon(TM) CPU 2.80GHz
CPU Speed 2.8 GHz
Cache Size 2048 KB
System Bogomips 22404.34
PCI Devices - Class ff00: Intel Corporation E7525/E7520 Error Reporting Registers
- Communication controller: Digium, Inc. Wildcard TE210P
- Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethernet PCI Express
- Host bridge: Intel Corporation E7520 Memory Controller Hub
- IDE interface: Intel Corporation 82801EB
- ISA bridge: Intel Corporation 82801EB/ER
- PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A
- PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B
- PCI bridge: Intel Corporation 82801 PCI Bridge
- PCI bridge: Intel Corporation E7520 PCI Express Port B1
- PCI bridge: Intel Corporation E7520 PCI Express Port C
- PCI bridge: Intel Corporation E7525/E7520 PCI Express Port B
- PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A
- PIC: Intel Corporation 6700/6702PXH I/OxAPIC Interrupt Controller A
- PIC: Intel Corporation 6700PXH I/OxAPIC Interrupt Controller B
- SMBus: Intel Corporation 82801EB/ER
- VGA compatible controller: ATI Technologies Inc Rage XL

IDE Devices - hda: DV-28E-N

SCSI Devices - ATA Maxtor 6L080M0 (Direct-Access)
- ATA ST380817AS (Direct-Access)

The problem is with Digium and Ethernet adapter. Digium TE210P has 2 E1 ports and it MUST have it's own IRQ, but it shares it with Ethernet controller:

cat /proc/interrupts:

CPU0 CPU1 CPU2 CPU3
0: 435 10004 34814710 4899099 IO-APIC-edge timer
1: 0 112 0 166 IO-APIC-edge i8042
8: 0 0 0 1 IO-APIC-edge rtc
9: 0 0 0 0 IO-APIC-level acpi
14: 1 24 0 19 IO-APIC-edge ide0
15: 0 0 49909 49777 IO-APIC-edge libata
169: 70310417 0 0 13421 IO-APIC-level wct2xxp, eth0
NMI: 0 0 0 0
LOC: 69726823 69726822 69726821 69726820
ERR: 0
MIS: 0

We see that wct2xxp and eth0 share IRQ 169.

The problem is how can we make them use different IRQs. I tried to disable onboard devices. I tried to disable first ethernet controller and enable the second.
Please give me some advice. Thank you in advance.

1 REPLY
Tony Davidson
Occasional Advisor

Re: DL140 interrupts problem

From what I understand about the Didium cards, this is a common problem and that some have had good luck with new drivers from Didium.
I would install different drivers, completely remove the card, reboot and then restart with the card back in to see if it gives a new IRQ.
Just an idea to bounce off of ya.