ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL185 / Linux / Java problem

Josh Bond
Occasional Visitor

DL185 / Linux / Java problem

I have a very resource intensive application that runs using Java. When I run this app on Windows 2003 ES x64 it (correctly) uses all available CPUs. However, in RedHat ES x86_64 it only uses one of those CPUs - pegged at 100%.

I have a hardware supported RAID5 partition where the application writes its data.

Most people I have asked told me to head to Linux forums for an answer, but I thought I would also post here in case someone has run across this issue in the past. Possibly it is a BIOS setting? I really am at a loss.

All firmware is up to date.

DL185 =
2 Quad core AMD Barcelona CPUs
32GB RAM

Thanks.
1 REPLY
Josh Bond
Occasional Visitor

Re: DL185 / Linux / Java problem

I made many mistakes during my setup. Here are the choices and changes I made to rectify the problem. I am still unsure which of these changes (if any) fixed the issue.

Orig: RedHat 5.2el5xen
New: RedHat 5.1el5
I removed the "xen" kernal by not choosing the "Virtualization" package during setup.

My RAID5 logical drive is named /dev/cciss/c0d1. Through BASH I ran this without ever creating a partition:
mkfs.ext3 /dev/cciss/c0d1
mkdir /mnt/raid5lcl
mount /dev/cciss/c0d1 /mnt/raid5lcl

So on the next setup I ran:
parted /dev/cciss/c0d1
mklabel gpt
mkpart primary ext3 0 2700GB
q #quit from "parted"
/sbin/mkfs.ext3 /dev/cciss/c0d1p1
mkdir /mnt/raid5lcl
mount /dev/cciss/c0d1p1 /mnt/raid5lcl

My system runs fine now.