ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL360-G3 Standard PXE boot order

 
Wiebe Niehof
Occasional Visitor

DL360-G3 Standard PXE boot order

Good day,

I've got a DL360-G3 server with 4 NIC's. (2x embedded and 2 PCI)
I want to PXE boot on these embedded nic's because I cannot disable 1 PCI (NC7170) NIC and he can't reach our backbone.

When I (manually) set the boot order it works fine. But when I deploy a new image with RDP it sets the PXE bootorder wrong. It sets the PCI Nic first.

RDP works with setcfg.bat which sets these settings along with some ini files. I've created these ini files with the " Capture Hardware Configuration" job when everything was manually set correct. But the NC7170 still takes priority over the embedded NIC.

I hope you can help me out.

Thanks,

Wiebe
7 REPLIES
Ruslan
Respected Contributor

Re: DL360-G3 Standard PXE boot order

Hi Wiebe!

There is option in RBSU to enable PXE boot on embeded adapters (System Options) and disable PXE on NC7170 pressing Ctrl+S when promt during booting process.
Wiebe Niehof
Occasional Visitor

Re: DL360-G3 Standard PXE boot order

Thanks for your quick response!

If this is true it's a great solution!

I've seen this menu before only I didn't find how I could do this.

I can change:
Boot strap Type
Hide Setup prompt
Setup Key Stroke
Banner Message Timeout
Link Speed
Pre-boot Wake On LAN

Ruslan
Respected Contributor

Re: DL360-G3 Standard PXE boot order

At first Disable PXE on both embeded adapters, change parameters of NC7170 and turn on back PXE of fisrt embeded NIC
Try to change Boot Strap Type (BBS mean BIOS Boot Specifications) and Pre-boot WOL to disable state. Post your results here, please.
Wiebe Niehof
Occasional Visitor

Re: DL360-G3 Standard PXE boot order

Ok,

I've disabled pxe on both the embedded nic's. Set Boot Strap on BBS and Disabled Wake On LAN Pre Boot.
Then I enabled PXE boot on the second Embedded NIC.(because that's the NIC on our backbone).

Unfortunately the adapter still tries to PXE boot.

I found this on an other forum, could this be an answer?

You need to use the Intel Boot Agent (IBA) to disable the PXE boot. The download location for IBA is:
http://downloadfinder.intel.com/scripts-df-external/confirm.aspx?ftpDown=ftp://aiedownload.intel.com/df-support/5651/eng/iba_g.zip&agr=&ProductID=991&DwnldId=5651&strOSs=&OSFullName=〈=eng

If the above link does not work, search Intel's support website for the 82546EB Gigabit Ethernet chipset. Be sure to download version 1.2.11 of the utility. I have tried the newer version 1.2.22 but it did not work with the NC7170.

You will need to copy the ibutil.exe file to a bootable DOS floppy. Boot from the floppy then type: ibautil

The utility will display the Ethernet devices in your system. Note the particular card number for your NC7170.

Re-run the utility with these options where x is the card number you noted above:
ibautil -nic=x -fd

The PXE boot should now be disabled.
Ruslan
Respected Contributor

Re: DL360-G3 Standard PXE boot order

I had the similar sitiation on the past... There is one NC7771 NIC and two embeded. During startup process there are many attemps to boot from NC7771 without link and late several minutes (10-15) it boot from embebed adapter themself!
Wiebe Niehof
Occasional Visitor

Re: DL360-G3 Standard PXE boot order

Hmm I could try that but that's far from ideal.
I will try the solution I posted above and let you know!
Wiebe Niehof
Occasional Visitor

Re: DL360-G3 Standard PXE boot order

Yes!
My remark above is the answer.

With Ibautil.exe you can set which PCI Nic has to PXE boot.

So you must make ibautil.exe part of your bootdisk and than give the correct commands. Ibautil helpfile will help you all the way!