ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HP ILO4 Remote console not connecting

freitasm
Occasional Collector

HP ILO4 Remote console not connecting

Hello folks

Runnig ILO4 2.50 at the moment. I've noticed that I can't start a .Net remote console session from my remote location - the ILO console starts and after 15 seconds it closes by itself.

I suspected it could be a firewall issue - it was working up until a month of so ago but just in case I had the DC recheck rules - I can connect over HTTPS and SSH from my IP but not the remote console.

I tested from a dev machine within the same network (no firewall between then) and it worked fine. To test I created a rule blocking outgoing port 23 connections from this dev machine and the remote console starts and closes instantly - different than the timeout behaviour I am seeing on my remote access.

TL;DR ILO4 2.50, firewall ports 80, 443, 22 and 23 open for specific IP, Web and SSH work fine but no remote console.

Anyone seen anything like this on 2.50 and the immediate previous version?

Thanks for your comments.

2 REPLIES
Jimmy Vance
HPE Pro

Re: HP ILO4 Remote console not connecting

iLO hasn't used port 23 for some time now

Check under Administration -Access settings to view the ports iLO uses

Secure Shell (SSH) Port 22
Remote Console Port 17990
Web Server Port 80
Web Server SSL Port 443
Virtual Media Port 17988

If the console starts and then closes I wouldn't assume it is a firewall issue. Try clearing the browser cache or download the stand-alone remote console client.

 

 

 

 

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
freitasm
Occasional Collector

Re: HP ILO4 Remote console not connecting

Thanks Jimmy

To make sure it wasn't a browser-specific thing I tried from different machines (a HP EliteBook, a Microsoft Surface and a HP MicroServer). The browsers had cookies cleared before testing. Also tried the stand-alone ILO Remote Console.

The Remote Console Port on my ILO is configured as 23 and has been for a while - since installed actually. Unless ILO 4 2.50 is automatically using 17990 despite the configuration.

I will have to ask for a change request for the datacentre to open up this port as well to test.