ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Install Suse 10.1 on HP DL320 G5 with Intel 82801GR Sata

Dleenkne
Occasional Visitor

Install Suse 10.1 on HP DL320 G5 with Intel 82801GR Sata

All,
I have following issue:

We want to install Suse 10.1 on a HP DL320G5 with an embedded Intel 82801GR Sata Raid controller.
I configured an array with 2 disks of 250GB in Raid 1.
When installing the Suse 10.1 OS the installation does not see the array created, but sees the different drives separately.
So after dearching a wile on the internet, a workaround was suggested:
- remove the array,
- put 1 disk in,
- install the system on 1 disk,
- install the correct driver,
- restart system,
- enable raid functionality in bios,
- create raid set with originating disk the disk installed with the os
- this should do…

Only…
When installing the driver found on the HP website: adpahci-1.2.5571-5.sles10.i586.rpm I receive following error:

Kernel supported is: 2.6.16.21-0.8
Can not install on 2.6.16.21-0.25

What would be the best solution for me to have Suse 10.1 installed on HP DL320G5 with Embedded RAID 1 Array set enabled and active for disk redundancy?
4 REPLIES
Mi6t0
Trusted Contributor

Re: Install Suse 10.1 on HP DL320 G5 with Intel 82801GR Sata

Try to fin Suse distribution with this kernel - then you will be able to enable the raid functionality and you will have the disk redundancy. Otherwise - you may try to find something on the intel website.

Regards,
Dleenkne
Occasional Visitor

Re: Install Suse 10.1 on HP DL320 G5 with Intel 82801GR Sata

I have not found that exact kernel to have suse installed that way.
Can anyone get me pointed to that version of Suse?

Thanks
Ciro Iriarte
Valued Contributor

Re: Install Suse 10.1 on HP DL320 G5 with Intel 82801GR Sata

Only SLES9 (SP3 $ SP4) and SLES10 (SP1) are supported... OpenSUSE 10.1 is not..

Re: Install Suse 10.1 on HP DL320 G5 with Intel 82801GR Sata

When SLES10 SP2 will be supported? Current adpahci-1.2.5571-5.sles10.x86_64.rpm supports SLES10, and SLES10 SP1. So I have following error:
falcon-cl1:/etc/apache2 # rpm -i ~barzog/adpahci-1.2.5571-5.sles10.x86_64.rpm
The currently running kernel (2.6.16.60-0.23-smp) is not
supported by this rpm. The supported kernels are:

2.6.16.21-0.8-default
2.6.16.21-0.8-smp
2.6.16.21-0.8-xen