ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing Centos 7 on ML310e Gen8 v2 (drivers for RAID-1 B120i controller)

SOLVED
Go to solution
SpookyX
Occasional Contributor

Installing Centos 7 on ML310e Gen8 v2 (drivers for RAID-1 B120i controller)

Has anyone succeeeded in installing Centos 7 on a server that has the B120i controller to see the controller (with RAID-1) configuration?

 

I have followed the steps found here:

http://h30499.www3.hp.com/t5/ProLiant-Servers-Netservers/How-to-install-Centos-7-0-with-RAID-1-on-Proliant-Microserver/td-p/6697850#.VP8GzfzLfYh

 

I tried these steps to use the RHEL 7.7 driver for Centos 7.0 install:

  1. Created a logical drive using RAID-1. In RBSU it is selected to be used as RAID controller and NOT AHCI.
  2. Downloaded the drivers and extracted them.

  3. Copied hpvsa-1.2.10-120.rhel7u0.x86_64.dd  to a USB Key formatted as FAT32 and renamed the .dd extension to .iso

  4. Started Centos 7 installtion

  5. On the main installation menu for CentOS, went to command prompt

  6. At the "boot" prompt enteredthe following command: linux dd blacklist=ahci

  7. Select ed the USB drive.

  8. Was asked about to select the image, I have confirmed the .iso file (from step 2)
  9. I was then asked about the rpm which was inside the iso, confirmed to use it.
  10. Centos installation resumed and went to select the logical (RAID-1) drive... but instead of it, I was seeing the two physical drives.

I did not used the iLO... physicial keyboard and mouse.

 

Any suggestion on doing it? Am I missing the right drivers or...?

3 REPLIES
Jimmy Vance
HPE Pro
Solution

Re: Installing Centos 7 on ML310e Gen8 v2 (drivers for RAID-1 B120i controller)

I made the same reply in the other thread also.

 

 

I've tested on both RHEL and CentOS 7.0 using hpvsa-1.2.10-120.rhel7u0.x86_64.dd.gz

 

download the driver

uncompress the .gz file

rename it from .dd to .iso

copy it to a fat formatted USB key

when you boot the installer add 'modprobe.blacklist=ahci inst.dd' on the boot line.

The above command is new for RHEL7.x, for 6.x it was just 'blacklist=ahci dd'. 

 

When the installer starts you will be prompted for the device, the file, and the package, for the driver update. When finished you have to select continue. (as hpvsa loads it may drop text on the screen where anaconda is waiting for input so the system may appear hung. If you press enter you get the driver options line refreshed)

 

In my case I think it was 1, 1, 1, c

 

When you get into the installer, you will see the HP Logical Volume in the disk selection.

 

At first I thought I was seeing two disks from the installer, but that was just a first glance mistake. My usb device showed up as sda at 1.90 GB, and the disk volume showed up as sdb at 1.90 TB. Once I smacked myself upside the head and selected the right device the installation continued.

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
SpookyX
Occasional Contributor

Re: Installing Centos 7 on ML310e Gen8 v2 (drivers for RAID-1 B120i controller)

Great!

 

I typed "linux modprobe.blacklist=ahci inst.dd" and it worked!

 

Thanks a lot.

dimasik005
Occasional Visitor

Re: Installing Centos 7 on ML310e Gen8 v2 (drivers for RAID-1 B120i controller)

Please help ! Who has send the file "hpvsa-1.2.10-120.rhel7u0.x86_64.dd.gz" on the email redhead1985@mail.ru, one that is on the site of any suitable (((