ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Network controller is installed but not working

 
SOLVED
Go to solution
Chokie
Visitor

Network controller is installed but not working

Hello Guys,

I brought ProLiant ML10 Gen 9 server, I installed Windows Server 2016 Standard. after I installed the OS and go to device manager to check th driver of the Ethernet... It's seem's the driver is already installed but when I plug the LAN Cable there is no connectivity between the LAN Cable and NIC... No LED is on.

Can anyone knows how to fix this thing? or same problem I have?

5 REPLIES
Coppens-Groep
Occasional Advisor

Re: Network controller is installed but not working

Did you try the LAN driver from the HPE support forum?

How many network ports do you have? Is it in the correct one? Is it set to DHCP or the correct static IP and subnet mask on the correct network port?

When you do ipconfig and a ping do you receive the normal information or do you get rare errors?

Chokie
Visitor

Re: Network controller is installed but not working

I downloaded the driver in HPE support and there's a lot of Network Driver there for windows server 2016. it's said The software will not be installed on tis sytem because the reqiured hardware is not present in the system or the software/firmware doesn't apply o this system. I think I downloaded everything in the HPE support.

In network properties I can see the Ethernet (network cable unplugged) but I already plug the LAN cable and I test the LAN cable it's working.

Is there anything I need to configure in BIOS? something I need to enable?

Coppens-Groep
Occasional Advisor
Solution

Re: Network controller is installed but not working

If you check in the device management (expand network adapters) with the current badly installed driver the complete name of the network card you can select the correct one on HPE with your serial number of the server.

It should then not give you the mentioned error.

If it gives you a different error, for example the driver you want to install is older then the one currently installed you accept that. Or first deinstall the current device through device management (Uninstall driver NOT disable device) you can then install the one downloaded which is corresponding with your name in the first step mentioned in this reply.

As mentioned in my first reply it could be the case that you have several network ports and an iLo port.

Make sure you connect it to the correct port.

If you are unable to get it working through this tips please provide a picture of the network port where you attached the cable to and also a screenshot of your network connections and network adapters in your device management.

Also if you provide the serial tag I can help you get the correct driver.

Chokie
Visitor

Re: Network controller is installed but not working

Thanks Bro.. my LAN is wokring right now... KUDOS!

Coppens-Groep
Occasional Advisor

Re: Network controller is installed but not working

Good to hear!

What was the solution? deinstall en then reinstall? Or one of the others?

Have fun with your server!