ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ProLiant Support Pack on Red Hat Linux 64

 
rijsbergen
Frequent Advisor

ProLiant Support Pack on Red Hat Linux 64

Hello,

 

it's definitely my rookie Linux knowledge but i can't find the proper stuff to instill or redirect to get the psp running.

 

server: Red Hat Enterprise Linux Server release 6.4 (Santiago)

hp psp: 9.10

copied psp from : http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=0&prodSeriesId=3716246&swItem=MTX-a980fae0949446edb051d4b75e&prodNameId=3716247&swEnvOID=4103&swLang=8&taskId=135&mode=4&idx=2

 

checking the pre-requisites i see all sorts of (here just 1 example):

libgcc.i686                       4.4.7-3.el6              @rhel-x86_64-server-6
libgcc.x86_64                     4.4.7-3.el6              @rhel-x86_64-server-6

To me it seems the 86 and 64 bits are there.

But starting the 'hpsum' i receive:

./hpsum: error while loading shared libraries: libuuid.so.1: cannot open shared object file: No such file or directory

 

In the /lib64 there is

-rwxr-xr-x 1 root root 18936 Jan  9 10:50 /lib64/libuuid.so.1.3.0
lrwxrwxrwx 1 root root    16 Feb 26 10:41 /lib64/libuuid.so.1 -> libuuid.so.1.3.0

I checked '/lib' for libuuid but it's not there, so i assume i still  mis some 32-bit stuf. I looked for the error and tried something like 'export  LD_LIBRARY_PATH' to point to the above /lib but obsiously i receive 'wrong ELF class'  being not the proper hardware.

 

Looking for 'red hat libuuid' in a search machine doesn't help a lot.

 

What Red Hat component do i need to get the proper libraries and/or what variables do i need to tell hpsum all's well.

 

regards,

Marcel

 

 

 

 

Moved from Servers>General to ProLiant Servers (ML,DL,SL)

Regards,
Marcel Rijsbergen
8 REPLIES
Matti_Kurkela
Honored Contributor

Re: ProLiant Support Pack on Red Hat Linux 64

Whenever you have library dependency issues, the "ldd" command might be helpful.

 

First, 'cd' to the directory that contains the hpsum binary as you did before.

Then, run this command:

ldd ./hpsum

 It will output a list of library names, and the pathnames where that library was found, or "Not found" if a library is missing.

Sometimes libraries can require other libraries, and the error messages are not always 100% accurate in those cases: if application A requires library B which requires library C, and C is missing, the error message may sometimes talk about library B instead of revealing the name of the missing library C.

 

The 'ldd' command can be used to list the dependencies of libraries too:

/lib$ ldd libuuid.so.1
        linux-vdso.so.1 =>  (0x00007ffffc3e2000)
        libc.so.6 => /lib/libc.so.6 (0x00007ff37a95b000)
        /lib64/ld-linux-x86-64.so.2 (0x00007ff37aeec000)

 

The "linux-vdso.so.1" is not a real library: it is a Virtual Dynamic Shared Object, related to a new faster method for performing system calls. On some older systems, it may be called "linux-gate.so.1" instead.

MK
rijsbergen
Frequent Advisor

Re: ProLiant Support Pack on Red Hat Linux 64

Thanx Matti,

 

that doesn't look ok i guess. But to me it looks to be the proper kit.

 

# ldd ./hpsum
        not a dynamic executable
# file ./hpsum
./hpsum: ELF 32-bit LSB executable, Intel 80386, version 1 (GNU/Linux), statically linked, stripped
# ll *gz
-rw-r--r-- 1 root root 139547602 Mar 25 11:07 psp-9.10.rhel6.x86_64.en.tar.gz

Regards, Marcel

 

Regards,
Marcel Rijsbergen
KimO_1
Advisor

Re: ProLiant Support Pack on Red Hat Linux 64

A quick way to resolve the Linux dependencies for HP SUM is to install the hpsum.rpm which will install the dependencies. hpsum.rpm can be found on the Linux SDR, www.hp.com/go/sdr under the Extras section. Information on hpsum.rpm can be found in the SPP Release Notes. hpsum.rpm for HP SUM 5.3.5 is not available yet, but you can install hpsum.rpm for 5.3.0 and then use the HP SUM 5.3.5 that is delivered with the RHEL 6.4 Supplement.
I work for HP.
DavidJHe
Occasional Visitor

Re: ProLiant Support Pack on Red Hat Linux 64

I tried downloading the HPSUM rpm package for RHEL6 x86_64 as per your instructions but was only able to find the i386 package, even when I followed the x86_64 links.  I am trying to run HPSUM from RHEL6.4 but am getting the same dependency errors as stated by the person in the orginal message.

Maurizio Terrin
Occasional Visitor

Re: ProLiant Support Pack on Red Hat Linux 64

Hello ,

 

I have an issue even more strange :

 

when I try to use the command hpsum from latest SSP supplemental for redhat 6.4 ,

the command complete immediately without error message.

 

I have checked all requirement library and packages  and all is OK.

 

Any suggestion ?

 

Thanks.

 

Maurizio 

yayadeo
Senior Member

Re: ProLiant Support Pack on Red Hat Linux 64

Problem solved ,

I had not installed all  i386 packages as require by installation instructions.

 

Bye,Maurizio

RobbertV
Occasional Visitor

Re: ProLiant Support Pack on Red Hat Linux 64

I'm experiencing exactly the same issues while trying to install HP SUM locally, the ldd results of the binary on the iso... I can't find the X86_64 version.


Did you already find a solution for this?

Re: ProLiant Support Pack on Red Hat Linux 64

Install the i386 version.  hpsum is a 32bit application.  The reason it is not finding libuuid is that it is looking for the 32-bit version.