ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

SCSI BIOS not installed / ML150G2, exchanged mainboard, RAID

 
jte2002
Occasional Visitor

SCSI BIOS not installed / ML150G2, exchanged mainboard, RAID

Hi,

I have an HP ML150G2 server and the mainboard got defected after a year. I got a new mainboard, but the problem seems to be that I had RAID 1 on the old mainboard (with the built-in SCSI controller) so the RAID configuration is not found on the new mainboard, so now if I boot up with the old 2 hard disks, I get "SCSI BIOS not installed" then something about "Int 13 device" and finally "No operating system found". The hard disks are still functional, because I have an identical server and they boot normally in that server.
Can I add the BIOS/RAID configuration without formatting the hard disks?
Or can I rebuild the SCSI BIOS from the hard disks?

Thanks
4 REPLIES
dms_1
Trusted Contributor

Re: SCSI BIOS not installed / ML150G2, exchanged mainboard, RAID

Hi,

in server BIOS check if the integrated controller is enabled (hardware raid).Is it possible to access the controller bios?
Blazhev_1
Honored Contributor

Re: SCSI BIOS not installed / ML150G2, exchanged mainboard, RAID

Hi,

if you have the Single Channel Ultra320 SCSI Adapter how did you made RAID 1 before?
Is it a software RAID?

Int 13h = interrupt 13 is normally used from tape drives.
If you have a second controller for a tape device, change in bios the boot order.

Pac
jte2002
Occasional Visitor

Re: SCSI BIOS not installed / ML150G2, exchanged mainboard, RAID

Thanks for the quick answers.

dms
I found no options for the controller in the server bios. however, i'm checking again, it seems the controller is pci not built-in. but it's for sure adaptec 2120S.
i can access the controller's bios but it doesn't seem to have useful options. it has configurations rather than utilities.

pac
it's a Single-Channel Ultra320 SCSI Adapter (adaptec 2120S). the supplier configured the servers before delivery. now the old mainboard isn't available anymore to consider taking its bios somehow, and the supplier doesn't have many options left except creating a new raid and i'd have to install everything again ;) that takes time and some specific configuration again. i was able to create system backups and full backups, but i don't want to risk the restoring process.

the accompanied HP CD has diagnostics, no utilities.
jte2002
Occasional Visitor

Re: SCSI BIOS not installed / ML150G2, exchanged mainboard, RAID

there are 2 menus for the scsi adapter, both accessible with Ctrl-A. the 2nd one shows something like this:

Manage Arrays
Create Array
Initialize..
Rescan Drives

But none recognizes the hard drives. Although they are recognized while booting.