Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

ILO3 incredible slow on VSP

Occasional Contributor

ILO3 incredible slow on VSP

[ Edited ]

Hi,

 

We are running DL585G7 / ILO3 with RHEL5.6. Of course we use VSP as we did on older ILO2 and ILO machine.

It works, but the kernels output is really slow, also the regular output to ttyS0 is slower than on ILO2

 

We've set 115200 wherever possible, but still no luck.

(wherever means ILO3, BIOS, grub.conf, kernel command line).

 

I think it gets even worse when one uses VSP and the (Java) Integrated Remote Console in parallel.

 

Also ipmi is really slow, here comparsion with ILO2:

 

$ time ipmitool -H ilo3 -I lanplus -U admin -P XXX fru
FRU Device Description : Builtin FRU Device (ID 0)
 Chassis Type          : Rack Mount Chassis
 Chassis Serial        : GB80323H9N     
 Board Mfg             : HP
 Board Product         : ProLiant DL585 G7
 Board Serial          : GB80323H9N     
 Board Part Number     : 590480-B21     
 Product Manufacturer  : HP
 Product Name          : ProLiant DL585 G7
 Product Part Number   : 590480-B21     
 Product Serial        : GB80323H9N     
 Product Asset Tag     :                               


real    0m7.347s
user    0m0.007s
sys     0m0.007s

$ time ipmitool -H ilo2 -I lanplus -U admin  -P XXX fru
FRU Device Description : Builtin FRU Device (ID 0)
 Chassis Type          : Rack Mount Chassis
 Chassis Part Number   : 455349-B21     
 Chassis Serial        : GB8821NF6P     
 Board Mfg             : HP
 Board Product         : ProLiant DL585 G5  
 Board Serial          : GB8821NF6P     
 Board Part Number     : 455349-B21     
 Product Manufacturer  : HP
 Product Name          : ProLiant DL585 G5  
 Product Part Number   : 455349-B21     
 Product Serial        : GB8821NF6P     
 Product Asset Tag     :                                


real    0m0.488s
user    0m0.001s
sys     0m0.003s

One can estimate the effects on ipmi sol sessions.

 

Is someone else facing this issue as well?

Any glue howto overcome this one?

 

thanks,

bernhard

 

EDITED: added ipmi facts

 

5 REPLIES
Occasional Advisor

Re: ILO3 incredible slow on VSP

I've got the same issue and I've reported it 1 year ago ...

 

On few G7 servers the VSP is in color mode and fast, I can't figure why.

 

 

 

Honored Contributor

Re: ILO3 incredible slow on VSP

Can you guys please test the iLO3 1.26 beta that I uploaded to the below FTP site? We tweaked VSP a bit, it is still slow during GRUB as this software won't use the UART FIFO but, it should be a lot faster once Linux is up and running.

 

 FTP Access: ftp://tempilo3:1wantiLO@ftp.usa.hp.com/

or: ftp://tempilo3:1wantiLO@15.192.32.78/

 




__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
Occasional Contributor

Re: ILO3 incredible slow on VSP

Thanks for pointing to the latest test firmwares, but we found that we faced another issue here.

 

BIOS managed to reset the speed automatically back to 9600 when rebooting the server with a VSP session attached.

So it didn't help that I set it manually to 115200 :)

 

The workaround to resolve this issue is setting the BIOS_Console fixed to COM1 instead of "AUTO".

Then the BIOS_Baud_Rate stays 115200 during reboots with vsp attached.

(HP 4632988444)

 

But still we face some performance problems (even with 1.26) when writing to /dev/console (from RHEL5.6):

When writing about 40k to /dev/console (dmesg output):

# dmesg | wc
   1101    8712   44256
; No user attached to VSP

# time dmesg > /dev/console

real   0m0.663s
user   0m0.003s
sys    0m0.010s

; User attached to VSP via ssh

# time dmesg > /dev/console

real   0m2.953s
user   0m0.001s
sys    0m0.010s

; User attached to VSP via ipmi (just tested for academical reasons)

# time dmesg > /dev/console

real   0m17.533s
user   0m0.006s
sys    0m0.007s

regards,

bernhard

 

 

 

Honored Contributor

Re: ILO3 incredible slow on VSP

Let's not compare against iLO2 since it was a completely different architecture.
How about the new iLO3 1.26 VSP compared against the physical COM port on the same server when set to 115200?



__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
Occasional Advisor

Re: ILO3 incredible slow on VSP

Hi Bernhard,

 

Did you ever get a resolution on your case 4632988444, regarding the speed change after a reboot?