Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

iLO DEAD after 1.82 Firmware in BL20p G2

Occasional Contributor

iLO DEAD after 1.82 Firmware in BL20p G2

Have successfully applied 1.82 firmware to 5 iLOs. #6 did not come back after automatic reboot following firmware upgrade.
Cannot access iLO remotely or via management port on front of blade. iLO is set to static IP.
Firmware was at 1.62 before.
Any suggestions?
12 REPLIES
Occasional Contributor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

Forgot to add...I have accessed the System Management Homepage for the server with the dead iLO, select Reset Integrated Lights-Out, and after selecting OK to question, I get the error 'HP Web Agent HTTP Post Error'.
Honored Contributor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

This sounds like a rough situation. Here is how I would recover:

1) shut down the blade.
2) pull it out of the enclosure
3) set the iLO security override switch
4) put in back in the enclosure
5) using the SUVI dongle, connect an external USB CD-ROM drive with the SmartStart firmware maintenance CD in it.
(You can download the CD)
http://h18023.www1.hp.com/support/files/server/us/smartstartinfo.html
6) boot the SmartStart CD and update the iLO firmware.
7) when you are done, restore the iLO security jumper
Occasional Contributor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

Any idea as to why this might have occurred?
I have 15 more to do but am uneasy with the success rate.
Does the client Java Version have any impact?
The machine applying the firmware updates has Java v1.4.1_04
I can upgrade, but this version has worked successfully on 9 out of 11 iLOs.
Thanks.
Occasional Contributor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

UPDATE:
1) shut down the blade.
2) pull it out of the enclosure
3) set the iLO security override switch
4) put in back in the enclosure
5) tried attaching to front via Ethernet, no response at all from iLO.

My questions are...the above one about version of Java client, and, is there a possible interim firmware that needs to occur going from
1.62 to 1.82?

Much appreciated...
Honored Contributor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

No, you should be able to update any iLO to the current version, 1.82. You do not need to take "baby steps" in between.

If the iLO is not responding, then it will also be unresponsive from the dongle. That is why I recommended booting to CD-ROM to recover. There is also a provision to get the flash component on a special bootable USB key and booting from there.

The host platform will still boot from the CD-ROM or USB attached device even if iLO is not responding.
Occasional Contributor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

Thanks again.
HP Support wanted me to upgrade my client Java Version to 1.4.2, as that is the recommended undocumented version.?.
Next, I was asked to upgrade from 1.62, to 1.70A, then to 1.82.
I followed these recommedations and the remainder of the iLOs are upgraded.
Hope this might help anyone else...
Occasional Visitor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

Is there an HP Document that says this? My company has changed out alot of motherboards due to a iLO firmware update. Even hooking up a monitor to the dongle it still doesn't show even after enabling iLO security override. Although the server does boot up. I am looking for the proper procedure to upgrade the iLO for the BL20p G2's.
Regular Advisor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

We have seen this same problem, but we see an additional catch: we tried to recover by first powering down completely, and then reinserting the server into the enclosure.

But the power button doesn't work anymore, even if the server has power...
There is def. something fishy about this...
Occasional Visitor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

If you are pressed to get the box back up there is a way to sortof fix it. If you flip off the iLO security. The box will boot back up fully. Although iLO will still not work. At least you can do that till you get your part. I have had to do that a few times. As far as HP and any other tech's. There is no fix for a bad flash of the iLO firmware. Also another note. I also noticed some of my customers tried flashing iLO and ROM at the same time and it has killed the ROM too.
Regular Advisor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

ehh.. let me just confirm that:

If I flick the security switch, the power button will work again?

That's interesting... will try that tomorrow.
Why the **** didn't HP support say that when I called them?
Last time this happened, they just sent a guy to change the system board.
Regular Advisor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

William, I forgot to ask: Did you try the suggestion about booting from a firmware update CD?
Occasional Visitor

Re: iLO DEAD after 1.82 Firmware in BL20p G2

Yes it will power on after you flip off the iLO security(pin 1) After I got it to boot. I used the dongle on the front with a monitor and keyboard and a usb cd-rom. No the firmware will not update on the iLO. I tried forceing it back. Older versions. I tried doing a online flash. I also even tried pushing it down with RDP. I didn't find anything that will fix the iLO after it has hit that state. Maybe you will have better luck. Let me know if you fix it because I kept 2 motherboards I was supposed to scrap. It would be nice to fix these so I can have these on hand in such an occasion it happens again.