Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Server Clustering
Showing results for 
Search instead for 
Did you mean: 

error while starting cmu service

Go to solution
Joshy PJ
Occasional Advisor

error while starting cmu service

I am getting below error while starting cmu service. I am able to start cmu by disabling “CMU_CHECK_TFTP_SERVER” in the configuration file.

Please let me know what may the issue …



[root@pa-st188 pxelinux.cfg]# /etc/init.d/cmu start


starting tftp server check ... done




*** tftp could not download /opt/cmu/ntbt/tftp/cmulinuz.x86_64 from <>

*** check that your tftp server exports /opt/cmu/ntbt/tftp and the cmu management ip address is correct

*** specific tftp servers (such as tftp-hpa for debian/ubuntu) may also require the --secure flag removed


*** on RHEL/SLES and clones also check that xinetd is started and well





*** note: setting CMU_CHECK_TFTP_SERVER to "no"

*** into /opt/cmu/etc/cmuserver.conf will bypass

*** this check (at your own risk)


*** tftp is required for all netboot operations (cloning/backup/autoinstall/diskless boot)



cmu:core(standard)         failed configuring

cmu:java                   not running

cmu:cmustatus              not running

cmu:monitoring             not running

cmu:dynamic user groups    unconfigured (cf /opt/cmu/etc/cmuserver.conf CMU_DYNAMIC_UG_INPUT_SCRIPTS)

cmu:web service            not running

cmu:nfs server             running

cmu:dhcpd.conf             no cmu header

cmu:high-availability      unconfigured


[root@pa-st188 pxelinux.cfg]# cat /etc/exports

#cmu_nfs_export_netboot_begin; do not remove or it will break cmu ; uninstall instead

/opt/cmu/ntbt/rp        *(sync,ro,no_all_squash,no_subtree_check,no_root_squash,fsid=4292137804)



[root@pa-st188 pxelinux.cfg]# cat /etc/xinetd.d/tftp

# default: off

# description: The tftp server serves files using the trivial file transfer \

#       protocol.  The tftp protocol is often used to boot diskless \

#       workstations, download configuration files to network-aware printers, \

#       and to start the installation process for some operating systems.

service tftp


        socket_type             = dgram

        protocol                = udp

        wait                    = yes

        user                    = root

        server                  = /usr/sbin/in.tftpd

        per_source              = 11

        cps                     = 100 2

        flags                   = IPv4

        server_args             = /opt/cmu/ntbt/tftp

        disable                 = no


[root@pa-st188 pxelinux.cfg]# cat /opt/cmu/ntbt/tftp

cat: /opt/cmu/ntbt/tftp: Is a directory

[root@pa-st188 pxelinux.cfg]# ll /opt/cmu/ntbt/tftp

total 5704

lrwxrwxrwx 1 1000 1000      17 Sep 18 22:10 cmulinuz -> ./cmulinuz.x86_64

-rw-r--r-- 1 1000 1000 5817760 Jan 16  2013 cmulinuz.x86_64

-rw-r--r-- 1 1000 1000   13148 Jun 20  2006 pxelinux.0

drwxr-xr-x 2 1000 1000    4096 Feb 25  2009 pxelinux.cfg

[root@pa-st188 pxelinux.cfg]#





Re: error while starting cmu service



When tftp doesn't work, it may either be a firewall issue (if the firewall is enabled), an SELinux issue (if SELinux is enabled), or a hostname issue. Regarding the hostname issue: make sure that localhost and the loopback IP and the hostname and IP address are both configured in the /etc/hosts file.


A good way to test your configuration is to run '/opt/cmu/bin/cmu_mgt_config -t'. If there are errors, then you can either fix them manually or run '/opt/cmu/bin/cmu_mgt_config -c' to properly configure your CMU management node.


Hope this helps.






Re: error while starting cmu service

Two more issues that we have seen with tftp:


1. The old /etc/xinetd.d/tftp_before_cmu_mgt_config is interfering with the new /etc/xinetd.d/tftp config. Make sure that /etc/xinetd.d/tftp is the only "tftp" file in /etc/xinetd.d/.


2. On some Linux distributions, when you restart the xinetd service the old tftpd daemon does not die, so the new tftp configuration is not processed. Run '/etc/init.d/xinetd stop' and then run 'ps ax | grep tftp', and if the daemon is still running then kill it. Then run '/etc/init.d/xinetd start' to restart it.




Joshy PJ
Occasional Advisor

Re: error while starting cmu service

thanks Chris ......
Occasional Visitor

Re: error while starting cmu service

What ended up fixing it?  Did you find multiple tftp* files in that directory, or?

Joshy PJ
Occasional Advisor

Re: error while starting cmu service

yes , there was , tftp.cmu_mgt_..  some file which was created by the rpm installation of cmu.. i removed all & restarted xinetd.d service . then its start workd .. :)